The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

URGENT: Mysql Problems after server2server move

Discussion in 'General Discussion' started by admin0, Jul 21, 2003.

  1. admin0

    admin0 Active Member

    Joined:
    Aug 11, 2002
    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    1
    Hi,

    We had to move domains from one cpanel server to another for one of our clients.
    error on all domains:


    Database error: cannot use database user_dbname
    MySQL Error: 1044 (Access denied for user: 'user_dbusername@localhost' to database 'user_dbname')
    Session halted.

    Warning: mysql_connect(): Access denied for user: 'user_dbusername@localhost' (Using password: YES)

    Warning: mysql_select_db(): supplied argument is not a valid MySQL-Link resource

    Warning: mysql_connect(): Access denied for user: 'username@localhost' (Using password: YES)


    Warning: mysql_select_db(): supplied argument is not a valid MySQL-Link resource

    and also errors like

    Warning: mysql_select_db(): supplied argument is not a valid MySQL-Link resource




    strangely enough:

    mysql -u user_dbusername -p
    can connect to mysql and pass arguments.

    This is happening for all the domains that use mysql :(

    cPanel.net Support Ticket Number:
     
  2. ciphervendor

    ciphervendor Well-Known Member

    Joined:
    Aug 26, 2002
    Messages:
    1,052
    Likes Received:
    0
    Trophy Points:
    36
    Try resetting the MySQL root password. Also verify that each user that can't connect to the database via the web has correct permissions on each database.

    cPanel.net Support Ticket Number:
     
  3. admin0

    admin0 Active Member

    Joined:
    Aug 11, 2002
    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    1
    Hi,


    reset of the mysql root password via WHM didn't helped.


    What else could be the problem that all of the sites that I moved are getting the same error.

    I moved around 250 sites using cpanel multi-copy providing the root pass for the other server.

    Around 25-35 are using mysql and all are getting the same error.


    beats me..

    cPanel.net Support Ticket Number:
     
  4. v-rod

    v-rod Well-Known Member

    Joined:
    Sep 18, 2002
    Messages:
    52
    Likes Received:
    0
    Trophy Points:
    6
    For some reason adding a user to the database and then removing the user always works for me... :rolleyes:

    cPanel.net Support Ticket Number:
     
Loading...

Share This Page