The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

URGENT Problem ! Mail

Discussion in 'E-mail Discussions' started by monoxide, Jun 29, 2004.

  1. monoxide

    monoxide Member

    Joined:
    Jun 14, 2004
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Hello and thanks in advance.

    We have a very bad problem :(

    PHP cannot send email, however if we send it via outlook express it works fine.

    But when php sends email from a forum or some thing like that it gives me the error ;

    This message was created automatically by mail delivery software.

    A message that you sent could not be delivered to one or more of its
    recipients. This is a permanent error. The following address(es) failed:

    *********@hotmail.com
    unrouteable mail domain "hotmail.com"

    ------ This is a copy of the message, including all the headers. ------

    Return-path: <*****@bubhost.com>
    Received: from nobody by neo.bubhost.com with local (Exim 4.34)
    id 1BfVEe-0000qW-D4
    for ********@hotmail.com; Wed, 30 Jun 2004 02:54:08 +0000
    To: *******@hotmail.com
    Subject: Registration at -= BubHost.Com Forums =- Feel free to ask questions and make comments :) ( From -= BubHost.Com Forums =- Feel free to ask questions and make comments :) )
    From: "-= BubHost.Com Forums =- Feel free to ask questions and make comments :)" <*******@bubhost.com>
    X-Priority: 3
    X-Mailer: IPB PHP Mailer
    Message-Id: <E1BfVEe-0000qW-D4@neo.bubhost.com>
    Date: Wed, 30 Jun 2004 02:54:08 +0000

    I have stars on the email addresses for certain reasons.

    We are running; exim (exim-4.34-60_cpanel_stmpcontrol_antivirus_rewrite_mailman2_mailtrap_exiscan)

    Please help!

    Thanks !
     
  2. monoxide

    monoxide Member

    Joined:
    Jun 14, 2004
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Please help!
     
  3. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    One reason is that you don't have phpsuexec enabled, but have checked the option in WHM > Tweak Settings > "Prevent the user 'nobody' from sending out mail to remote addresses"

    You need to either uncheck that, or enable phpsuexec.
     
  4. monoxide

    monoxide Member

    Joined:
    Jun 14, 2004
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    how do i enable, or install phpsuexec?

    Thanks !
     
  5. Jaime

    Jaime Active Member

    Joined:
    Aug 20, 2003
    Messages:
    31
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Palma de Mallorca
    You have to recompile apache using easyapache from either commandline WHM (select last option "phpsuexec"). Anyway, I wouldnt recommend you to enable phpsuexec; I would simply uncheck "Prevent the user 'nobody' from sending out mail to remote addresses".

    Jaime
     
  6. monoxide

    monoxide Member

    Joined:
    Jun 14, 2004
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    I have tryed that but it still doesn't work !
     
  7. Jaime

    Jaime Active Member

    Joined:
    Aug 20, 2003
    Messages:
    31
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Palma de Mallorca
    I'm sorry, I forgot something important: In WHM, goto Server Setup -> Enable/Disable SuExec and enable SuExec there.

    Jaime
     
  8. monoxide

    monoxide Member

    Joined:
    Jun 14, 2004
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    fixed
     
Loading...

Share This Page