URGENT: Problem with account transfers

haze

Well-Known Member
Dec 21, 2001
1,550
3
318
After moving the permissions for an account was username:551

the next acount was username:551. I fixed the perms, but cant log into the account? What do I need to do?

EDIT: I get this in var/log/messages:
Apr 3 20:51:34 pearljam proftpd[1506]: pearljam.nameserve.org (CPE-203-45-136-241.qld.bigpond.net.au[203.45.136.x]) - FTP session opened.
Apr 3 20:51:35 pearljam proftpd[1506]: pearljam.nameserve.org (CPE-203-45-136-241.qld.bigpond.net.au[203.45.136.x]) - Unable to open password file /etc/proftpd/passwd.vhosts for reading: No such file or directory
Apr 3 20:51:35 pearljam last message repeated 5 times
Apr 3 20:51:35 pearljam proftpd[1506]: pearljam.nameserve.org (CPE-203-45-136-x.qld.bigpond.net.au[203.45.136.x]) - no such user 'username'
Apr 3 20:51:35 pearljam proftpd[1506]: pearljam.nameserve.org (CPE-203-45-136-x.qld.bigpond.net.au[203.45.136.x]) - FTP session closed.

EDIT2:

I copied the etc/proftpd/ folder as it was non existant on the new server.. loging in works now, but when I log in, I see no files or folders. If I switch to a directory manually like www, I can however.
 
B

bdraco

Guest
[quote:698e468d59][i:698e468d59]Originally posted by iminteractive[/i:698e468d59]

After moving the permissions for an account was username:551

the next acount was username:551. I fixed the perms, but cant log into the account? What do I need to do?

EDIT: I get this in var/log/messages:
Apr 3 20:51:34 pearljam proftpd[1506]: pearljam.nameserve.org (CPE-203-45-136-241.qld.bigpond.net.au[203.45.136.x]) - FTP session opened.
Apr 3 20:51:35 pearljam proftpd[1506]: pearljam.nameserve.org (CPE-203-45-136-241.qld.bigpond.net.au[203.45.136.x]) - Unable to open password file /etc/proftpd/passwd.vhosts for reading: No such file or directory
Apr 3 20:51:35 pearljam last message repeated 5 times
Apr 3 20:51:35 pearljam proftpd[1506]: pearljam.nameserve.org (CPE-203-45-136-x.qld.bigpond.net.au[203.45.136.x]) - no such user 'username'
Apr 3 20:51:35 pearljam proftpd[1506]: pearljam.nameserve.org (CPE-203-45-136-x.qld.bigpond.net.au[203.45.136.x]) - FTP session closed.

EDIT2:

I copied the etc/proftpd/ folder as it was non existant on the new server.. loging in works now, but when I log in, I see no files or folders. If I switch to a directory manually like www, I can however.
[/quote:698e468d59]

chrgrp -R /etc/proftpd
 

haze

Well-Known Member
Dec 21, 2001
1,550
3
318
chrgrp -R /etc/proftpd

I got command not found, and..

chgrp -R /etc/proftpd

chgrp: too few arguments
 
B

bdraco

Guest
[quote:5e29a4a9ba][i:5e29a4a9ba]Originally posted by bdraco[/i:5e29a4a9ba]

[quote:5e29a4a9ba][i:5e29a4a9ba]Originally posted by iminteractive[/i:5e29a4a9ba]

After moving the permissions for an account was username:551

the next acount was username:551. I fixed the perms, but cant log into the account? What do I need to do?

EDIT: I get this in var/log/messages:
Apr 3 20:51:34 pearljam proftpd[1506]: pearljam.nameserve.org (CPE-203-45-136-241.qld.bigpond.net.au[203.45.136.x]) - FTP session opened.
Apr 3 20:51:35 pearljam proftpd[1506]: pearljam.nameserve.org (CPE-203-45-136-241.qld.bigpond.net.au[203.45.136.x]) - Unable to open password file /etc/proftpd/passwd.vhosts for reading: No such file or directory
Apr 3 20:51:35 pearljam last message repeated 5 times
Apr 3 20:51:35 pearljam proftpd[1506]: pearljam.nameserve.org (CPE-203-45-136-x.qld.bigpond.net.au[203.45.136.x]) - no such user 'username'
Apr 3 20:51:35 pearljam proftpd[1506]: pearljam.nameserve.org (CPE-203-45-136-x.qld.bigpond.net.au[203.45.136.x]) - FTP session closed.

EDIT2:

I copied the etc/proftpd/ folder as it was non existant on the new server.. loging in works now, but when I log in, I see no files or folders. If I switch to a directory manually like www, I can however.
[/quote:5e29a4a9ba]

chrgrp -R /etc/proftpd[/quote:5e29a4a9ba]

Sorry .. missed a word

chgrp -R proftpd /etc/proftpd
 

haze

Well-Known Member
Dec 21, 2001
1,550
3
318
I already tried that and it didn't work, it was unaccepted group, I think I got.

What I have done is this, there was no /etc/proftpd/ folder on the new server, so I ziped up the one on the old server and unziped it. I was then able to log in but not see anything or upload ( could download ). I then ran scripts/upcp and I seem to be rolling fine now. I just need to change the ownerships back for the accounts the WHM Transfer messed up. FYI, I think it messes up the ownership of accounts that have FP installed, as I didn't have a problem with non FP accounts and permissions.. Anyway, I am hoping this is fixed now :)