Urgent!!! Pure-ftpd Cant Log To Ftp !!!

bsasninja

Well-Known Member
Sep 2, 2004
527
0
166
I was using WHM 11.2.0 cPanel 11.6.0-R15076 version in one of my servers and pureftpd stopped. Whm status was green (running)service but all accounts of the server gaves 530 authentication error.
So I did the following:

service pure-ftpd restart -> gives ok, but nothing happens
/etc/init.d/pureftpd restart -> gives ok, but nothing happens
restart service from whm -> gives ok, but nothing happens
syncronize ftp passwords from whm -> gives ok, but nothing happens
/scripts/ftpup --force -> gives ok, but nothing happens

Then I did /scripts/upcp --force and now I have latest cpanel version WHM 11.2.0 cPanel 11.10.0-R16448.
Then again /scripts/ftpup --force again but the problem is still present.

How can I fix this my customers cant log to ftp and I´m receiving complaints!!

Thanks!
 
Last edited:

bsasninja

Well-Known Member
Sep 2, 2004
527
0
166
Fixed, I just uncommented the line at /etc/pure-ftpd.conf
UnixAuthentication yes

This is very weird, I never touched this before :confused: also I have a lot of server with this feature commented and they are working fine.

At least its fixed, but will be nice to hear a logic explation for this.
 

apogee

Well-Known Member
Nov 8, 2004
122
11
168
Europe
cPanel Access Level
DataCenter Provider
i had the same problem today on cpanel 10 after nightly upcp, upcp installed a wrong /usr/sbin/pureauth on the system.

way to solv: simply copy /usr/sbin/pureauth from another cpanel server with scp to the server with the problem
 

cPanelDavidG

Technical Product Specialist
Nov 29, 2006
11,216
11
313
Houston, TX
cPanel Access Level
Root Administrator
i had the same problem today on cpanel 10 after nightly upcp, upcp installed a wrong /usr/sbin/pureauth on the system.

way to solv: simply copy /usr/sbin/pureauth from another cpanel server with scp to the server with the problem
If you are still running version 10, I strongly recommend upgrading to version 11 as version 10 is no longer being maintained.
 

meweb

Well-Known Member
Feb 10, 2003
58
0
156
Great

Hello Buddy,

that does the trick :)




Fixed, I just uncommented the line at /etc/pure-ftpd.conf
UnixAuthentication yes

This is very weird, I never touched this before :confused: also I have a lot of server with this feature commented and they are working fine.

At least its fixed, but will be nice to hear a logic explation for this.