SOLVED URGENT: upcp and httpd update killed all websites

bloatedstoat

Well-Known Member
Jun 14, 2012
181
24
68
Victoria, Australia
cPanel Access Level
Root Administrator
This is pretty urgent, I have submitted a support ticket request 94283332. CLOUDLINUX 6.10 v92.0.11

In the mean time has anyone experienced issues with upcp updating httpd and creating the following errors?

We do not have any websites operational at the moment, all failing with white screen on load, WHMCS is reporting an ioncube error for php7.3 with ioncube loader enabled. Seems like crucial modules are not being loaded across all PHP versions.

ERROR - 2021-02-27 04:27:10 --> Severity: error --> Exception: Call to undefined function mysqli_init() /home/username/public_html/system/database/drivers/mysqli/mysqli_driver.php 135
ERROR - 2021-02-27 04:27:10 --> Severity: Core Warning --> PHP Startup: Unable to load dynamic library 'wddx.so' (tried: /opt/alt/php74/usr/lib64/php/modules/wddx.so


Is this a recompile with Easy Apache?

Thanks
 

bloatedstoat

Well-Known Member
Jun 14, 2012
181
24
68
Victoria, Australia
cPanel Access Level
Root Administrator
It seems that no modules are being loaded at all.
I tried to recompile with EasyApache and I'm getting all this when I try top do so.

Error: Package: 1:ea-php74-php-cli-7.4.15-1.el6.cloudlinux.x86_64 (cl-ea4)
Requires: ea-openssl11 = 1:1.1.1h
Installed: 1:ea-openssl11-1.1.1i-1.el6.cloudlinux.x86_64 (@cl-ea4)
ea-openssl11 = 1:1.1.1i-1.el6.cloudlinux

Available: ea-openssl11-1.1.1h-1.1.1.cpanel.x86_64 (EA4)
ea-openssl11 = 1.1.1h-1.1.1.cpanel

Available: ea-openssl11-1.1.1h-1.1.2.cpanel.x86_64 (EA4)
ea-openssl11 = 1.1.1h-1.1.2.cpanel

Available: ea-openssl11-1.1.1i-1.1.1.cpanel.x86_64 (EA4)
ea-openssl11 = 1.1.1i-1.1.1.cpanel

Available: ea-openssl11-1.1.1j-1.1.1.cpanel.x86_64 (EA4)
ea-openssl11 = 1.1.1j-1.1.1.cpanel

Available: 1:ea-openssl11-1.1.1d-1.el6.cloudlinux.x86_64 (cl-ea4)
ea-openssl11 = 1:1.1.1d-1.el6.cloudlinux

Available: 1:ea-openssl11-1.1.1f-1.el6.cloudlinux.x86_64 (cl-ea4)
ea-openssl11 = 1:1.1.1f-1.el6.cloudlinux

Available: 1:ea-openssl11-1.1.1g-1.el6.cloudlinux.x86_64 (cl-ea4)
ea-openssl11 = 1:1.1.1g-1.el6.cloudlinux

Available: 1:ea-openssl11-1.1.1h-1.el6.cloudlinux.x86_64 (cl-ea4)

ea-openssl11 = 1:1.1.1h-1.el6.cloudlinux
The entire output was logged to: /usr/local/cpanel/logs/packman/errors/2021-02-27_08:49:10-1
 

bloatedstoat

Well-Known Member
Jun 14, 2012
181
24
68
Victoria, Australia
cPanel Access Level
Root Administrator
$30USD later and this issue was resolved by tech support.


The described issue is a known issue in CloudLinux package ea-apache24-2.4.46-6.el7.cloudlinux.x86_64, which this server had updated to. I downgraded all ea-apache24 packages as a workaround:

yum downgrade ea-apache24*

CloudLinux staff has stated that they will be removing the package from their mirrors, and to downgrade any servers that have already received the update to ea-apache24-2.4.46-6.el7.cloudlinux.x86_64.


Hope this is helpful to anyone else who has this issue.
 
  • Like
Reactions: andrew.n