The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

url defaults to setup page

Discussion in 'General Discussion' started by caeos, Aug 28, 2008.

  1. caeos

    caeos Well-Known Member

    Joined:
    Jul 18, 2007
    Messages:
    79
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    UK
    I am not sure if this is the best way to descrtbe this but.
    when i type the www.domain.com i get the lxadmin (even though its on cpanel) page, but when i type www.domain.com/index.htm i get the proper site page.

    i can type www.domain.com/cpanel etc to get into the account. It also the same manor of viewing when i drop the 'www'

    Ideas and suggestions please
     
  2. MaestriaNick

    MaestriaNick Well-Known Member

    Joined:
    Aug 6, 2008
    Messages:
    159
    Likes Received:
    3
    Trophy Points:
    18
    may be some index file is in your public_html folder, which have higher preference than index.html (defined as DirectoryIndex , in your httpd.conf file or in your .htaccess ) , which your host put by default . So search for such files. May be some home.htm , home.html or index.htm .

    If you want to load this index.html by default, just add this line in the .htaccess file in your public_html folder


    DirectoryIndex index.html
     
  3. caeos

    caeos Well-Known Member

    Joined:
    Jul 18, 2007
    Messages:
    79
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    UK
    thanks, but let me clarify;
    -there is no default index page in the skel directory.
    -the htaccess directive forces the html page then the php neither of these are the lxadmin page.
    - i can not get in to ssh anything as i am not on my normal network but do have whm access.
     
  4. MaestriaNick

    MaestriaNick Well-Known Member

    Joined:
    Aug 6, 2008
    Messages:
    159
    Likes Received:
    3
    Trophy Points:
    18
    is there already any .htaccess in the public_html with some redirect rules ?

    can you try adding

    DirectoryIndex index.html

    in to the .htaccess file ?
     
  5. caeos

    caeos Well-Known Member

    Joined:
    Jul 18, 2007
    Messages:
    79
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    UK
    as stated (but prob not vlearly)
    the issues is when i do not type any actual page reference into the website address, just the domain name.

    i have seemingly now resolved the situation by alter the php ini directory path to use index.html
    this may have been something corrupted in the set up but has never happened on any of the other vps/servers i set up
     
  6. MaestriaNick

    MaestriaNick Well-Known Member

    Joined:
    Aug 6, 2008
    Messages:
    159
    Likes Received:
    3
    Trophy Points:
    18
    yea, this is strange, as there is no other index or home pages in your document root and no .htaccess. Can you please update here, if you manage to find the problem ?
     
  7. caeos

    caeos Well-Known Member

    Joined:
    Jul 18, 2007
    Messages:
    79
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    UK
    it hasnt happened since that i can see, and i am just setting up another vps so we will see what happens this time.
     
Loading...

Share This Page