Use Cloudflare’s nameservers on my server?

mikailkeerp

Registered
Aug 22, 2019
1
0
1
Sweden
cPanel Access Level
Website Owner
I purchased VPS hosting from Namecheap with cPanel and WHM installed on the server. I intend to run Xenforo forum software on it, but I’m having trouble figuring out how to properly set up the Basic WHM setup.

This is what I’ve tried (which does not work):

–> At the domain registrar, the nameservers are changed to my assigned Cloudflare nameservers.

–> At Cloudflare, DNS type A records point to my server main IP address.

–> In cPanel/WHM, the namerservers are also changed to the assigned cloudflare nameservers.

When I visit the page, I get the default cPanel error page telling me there may be a server misconfiguration/DNS settings may be setup incorrectly. So, I’m obviously doing something wrong, and I’m guessing it’s because I haven’t configured my own nameservers for the server since that’s what you usually are supposed to do, as far as I understand. When I check out namecheaps support page, all I can find is this:

“If you have Namecheap VPS or Dedicated server with WHM/cPanel installed, you can register your own nameservers (ns1(dot).yourdomain(dot).com and ns2(dot)yourdomain(dot)com).”

Here is the initial setup guide I’ve followed:
namecheap.com/support/knowledgebase/article.aspx/9409/48/how-to-configure-initial-whm-settings-vps-and-dedicated-server#step1

I really do appreciate all help.
 
Last edited by a moderator:

Jcats

Well-Known Member
PartnerNOC
May 25, 2011
797
152
168
New Jersey
cPanel Access Level
DataCenter Provider
–> In cPanel/WHM, the namerservers are also changed to the assigned cloudflare nameservers.
Not necessary, since you are using CloudFlare, all the DNS related records are hosted there.

Go into WHM > List Accounts

Are you saying the IP shown in this list is the same IP you have set in CloudFlare?

Ensuring that the record in CloudFlare is an "A Record" for the root of your domain and as well as your 'www' record which might be a CNAME pointing to your root domain.

Its also possible that you visited your domain prior to it being setup in cPanel but DNS was pointed to your IP so you have the default cPanel page cached in your browser, you can test using Incognito mode or clearing browser history or open up developer console, goto the network tab and check the box 'disable cache'.
 
  • Like
Reactions: cPanelLauren