The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Use cPanel as webserver and a external mailserver

Discussion in 'E-mail Discussions' started by HappyCoder, Apr 30, 2012.

  1. HappyCoder

    HappyCoder Member

    Joined:
    Apr 27, 2012
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hi,

    I use an external DNS when I point the A record (not the MX record) of the domain into cPanel platform. In cPanel, I have configured the domain name. We call the domain name abc.com
    My problem is that I want to keep mail on a external mailserver, but when I send an email to xxx@abc.com from the Webserver on cPanel or from another domain that was created in cPanel, I get an error mail back. The error message is: The user xxx@abc.com does not exist.
    How can I force cPanel to understand that the mailserver is not hosted in cPanel?

    Keep me happy,
    HappyCoder
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    650
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Please contact your web hosting provider and have them use the following option within Web Host Manager:

    "WHM >> DNS Functions >> Edit DNS Zone"

    Under "Email Routing", ensure that "Remote Mail Exchanger" is selected.

    Thank you.
     
  3. HappyCoder

    HappyCoder Member

    Joined:
    Apr 27, 2012
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hello,

    It's beautiful! - I've now changed it from being the "Automatically Detect Configuration (recommended)" to "Remote Mail Exchanger" under "MX Entry". It has solved my problem
    Thanks for your help!

    I'm still happy;-)
    HappyCoder
     
Loading...

Share This Page