The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Use old style passwords with MySQL

Discussion in 'General Discussion' started by bhd, Nov 22, 2007.

  1. bhd

    bhd Well-Known Member

    Joined:
    Sep 20, 2003
    Messages:
    149
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    JNB ZA
    cPanel Access Level:
    Root Administrator
    For some reason this setting does not seem to work on one server. After an update to 11.15.0-R18033 everything MySQL broke. I immediately thought of "Use old style (4.0) passwords with MySQL® 4.1+ (required if you have problems with PHP apps authenticating)" under "tweak settings" and saw it was off. I enabled it but it had no effect.

    (I have subsequently unchecked it and checked it again. No difference).

    I then tried to do it manually:

    mysql> set password=password('SamePasswordAsBefore');

    and it works so the problem is definitely with MySQL 4.1 password hash length, but the setting in cPanel is not doing anything. Besides checking that checkbox, is there anything else one has to do? ... because I r-e-a-l-l-y don't want to have to manually re-save every MySQL password on the server.

    [edit]

    I checked and /etc/my.cnf has the line which I presume corresponds to the directive in WHM -> Tweak Settings -> Use old style (4.0) passwords with MySQL® 4.1+:

    old-passwords = 1
     
    #1 bhd, Nov 22, 2007
    Last edited: Nov 22, 2007
  2. bhd

    bhd Well-Known Member

    Joined:
    Sep 20, 2003
    Messages:
    149
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    JNB ZA
    cPanel Access Level:
    Root Administrator
    I think I found the fix. Ran /scripts/realperlinstaller --force DBD::mysql and that seems to have sorted out the problem.
     
Loading...

Share This Page