The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

User not permitted to relay mail?

Discussion in 'E-mail Discussions' started by LoganH, Jun 15, 2007.

  1. LoganH

    LoganH Member

    Joined:
    Jun 27, 2006
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    I receive this in every e-mail I send out. The message is to that e-mail address but I get a mail delivery system e-mail right back as soon as I send it with the person I sent it to in the header of the error (the @gmail address).

    Is there anything I should look for? I checked in the PHP sendmail function but it is sent properly to /usr/sbin/sendmail.

    edit: please move to exim forum, I wasn't looking
     
  2. mohit

    mohit Well-Known Member

    Joined:
    Jul 12, 2005
    Messages:
    553
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Sticky On Internet
    seems you have restricted "nobody user" from relaying mails to remote domains.
    if this is the case you would need to allow the "nobody mails" as php runs as user nobody on server.

    mohit
     
  3. anand

    anand Well-Known Member

    Joined:
    Nov 11, 2002
    Messages:
    1,435
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    India
    cPanel Access Level:
    DataCenter Provider
    Gid 32110 is not permitted to relay mail

    I am seeing the same issue with a customer server running kayako helpdesk.

    Code:
    2007-07-01 12:52:29 1I53b2-0002Fs-TB ** xxxx@xxxx.com R=checkspam2: Gid 32110 is not permitted to relay mail, or has directly called /usr/sbin/exim instead of /usr/sbin/sendmail.
    
    User nobody is allowed to send mails from the server. Does anyone else see the same issue ? Any suggestions on solution ?
     
  4. anand

    anand Well-Known Member

    Joined:
    Nov 11, 2002
    Messages:
    1,435
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    India
    cPanel Access Level:
    DataCenter Provider
    Problem resolved after resetting exim to default. Strange, since there was no custom mods in exim.conf at the first place and all spam assassin settings were switched off from whm.
     
  5. Starcraftmazter

    Starcraftmazter Well-Known Member

    Joined:
    May 5, 2006
    Messages:
    47
    Likes Received:
    0
    Trophy Points:
    6
    Yo.

    I'm, having the same problem now, seems to be recent.

    What do you mean reset exim to default? Reset the config? I tried that, and the problem still occurs =/
     
  6. OneSoul

    OneSoul Registered

    Joined:
    Mar 29, 2005
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    There may be other causes for it. One of it could be
    incorrect permissions on /usr/sbin/sendmail

    Make sure the group has sgid permission.

    root@admin [~]# ll /usr/sbin/sendmail
    -rwxr-xr-x 1 root mailtrap 10548 May 7 16:36 /usr/sbin/sendmail*

    root@admin [~]# chmod g+s /usr/sbin/sendmail

    root@admin [~]# ll /usr/sbin/sendmail
    -rwxr-sr-x 1 root mailtrap 10548 May 7 16:36 /usr/sbin/sendmail*


    Source : http://www.etechsupport.net/forum/showthread.php?t=1018


    Best Regards,
     
  7. myBox

    myBox Active Member

    Joined:
    Jan 6, 2004
    Messages:
    40
    Likes Received:
    0
    Trophy Points:
    6
    same problem here



    Thank you very much this exactly was my problem

    it all started when I used
    /scripts/secureit - Remove unnecessary suid binaries.

    it even removed the sticky bit from ping when nagios went crazy!!!

    damn it!

    small thigs like this make you pull your hair out until you have none left ::confused:
     
  8. caezar

    caezar Registered

    Joined:
    Apr 15, 2004
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    worked !

    indeed, this solved my problem too.

    I also used the script/securit

    thanks,
     
Loading...

Share This Page