The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

user php.ini ignored

Discussion in 'General Discussion' started by EWD, Dec 11, 2007.

  1. EWD

    EWD Well-Known Member
    PartnerNOC

    Joined:
    Aug 19, 2003
    Messages:
    165
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    NY
    Hi Guys,

    I have a user that needs register_globals turned on.
    I did this creating a local php.ini file however the system seems to be ignoring it.
    Safe PHP CGI is not enabled on the server.

    I have created a phpinfo file on the account and it does show register_gloabls on as well as the location of the local php.ini file.


    Any ideas?
    Running php4.4.7

    Thanks.
     
  2. EWD

    EWD Well-Known Member
    PartnerNOC

    Joined:
    Aug 19, 2003
    Messages:
    165
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    NY
    Anyone have an idea?
     
  3. mtindor

    mtindor Well-Known Member

    Joined:
    Sep 14, 2004
    Messages:
    1,279
    Likes Received:
    36
    Trophy Points:
    48
    Location:
    inside a catfish
    cPanel Access Level:
    Root Administrator
    Wait.

    1. you say you WANT register_globals on
    2. you say you created a PHP.INI to turn ON register_globals
    3. you say that phpinfo shows register_globals is ON

    But you say the system is ignoring PHP.INI?

    Doesn't sound to me like it's ignoring PHP.INI if phpinfo shows register_globals on

    Remember - with php.ini, you can't just stick it in public_html and have it take effect for every directory beneath it. You have to copy that php.ini file to any directory that has PHP content that requires the settings in the php.ini file

    Mike
     
  4. ashokpomnar

    ashokpomnar Active Member

    Joined:
    Sep 30, 2006
    Messages:
    28
    Likes Received:
    0
    Trophy Points:
    1
    Hello,

    Please create .htaccess file and add following value

    php_value register_globals 1
    php_flag register_globals On
     
  5. EWD

    EWD Well-Known Member
    PartnerNOC

    Joined:
    Aug 19, 2003
    Messages:
    165
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    NY

    I guess that is where the issue is.
    I thought it used to cascade down to subdirectories?

    Thanks Mike ;)
     
  6. mtindor

    mtindor Well-Known Member

    Joined:
    Sep 14, 2004
    Messages:
    1,279
    Likes Received:
    36
    Trophy Points:
    48
    Location:
    inside a catfish
    cPanel Access Level:
    Root Administrator
    Yeah unfortunately it doesn't cascade. If you weren't running SUPHP you'd be able to put it in the .htaccess file (which does cascade). But the damned php.ini has to be put into every directory where you want settings to take effect. A real pain in the ass, but I'd rather run suphp and deal with it.

    - mike
     
  7. EWD

    EWD Well-Known Member
    PartnerNOC

    Joined:
    Aug 19, 2003
    Messages:
    165
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    NY
    Yea I wouldn't do away with suphp either.

    Thanks for the help ;)
     
Loading...

Share This Page