The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

user@server.tld -> mailbox@domain.tld

Discussion in 'E-mail Discussions' started by Wabun, Jul 11, 2015.

  1. Wabun

    Wabun Well-Known Member

    Joined:
    Oct 6, 2012
    Messages:
    56
    Likes Received:
    2
    Trophy Points:
    8
    Location:
    Antwerpen
    cPanel Access Level:
    Root Administrator
    Hi all,

    Is it possible to change the behaviour as explained above?
    My user finds it annoying that it sends out emails in that way.

    I am Using WHM 11.48.4 (build4)

    Have the experimental function enabled to rewrite From: header to match actual sender.
     
    #1 Wabun, Jul 11, 2015
    Last edited: Jul 11, 2015
  2. 24x7server

    24x7server Well-Known Member

    Joined:
    Apr 17, 2013
    Messages:
    1,146
    Likes Received:
    34
    Trophy Points:
    48
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Hello,

    I think you are sending mail through php scripts using the php mail function and due to server is sending all mail through user@hostname. You need to use SMTP authentication in your script instead of php mail function
     
  3. Wabun

    Wabun Well-Known Member

    Joined:
    Oct 6, 2012
    Messages:
    56
    Likes Received:
    2
    Trophy Points:
    8
    Location:
    Antwerpen
    cPanel Access Level:
    Root Administrator
    Hi, yes I was afraid for such answer, the problem is that many different websites having same issue, WordPress, TYPO3 and many others, I was hoping for a more elegant solution. WP is very difficult to do for the average user as there is no plug-in able to fix it, so you need to hard-code/modify the php mail script. Thanks for your reply anyway.
     
  4. 24x7server

    24x7server Well-Known Member

    Joined:
    Apr 17, 2013
    Messages:
    1,146
    Likes Received:
    34
    Trophy Points:
    48
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Hello,

    If your user are sending these mail through contact form, Then you can use CONTACT FORM 7 plugin for word-press. With this plugin setting you can use SMTP function instead of php mails.
     
  5. Wabun

    Wabun Well-Known Member

    Joined:
    Oct 6, 2012
    Messages:
    56
    Likes Received:
    2
    Trophy Points:
    8
    Location:
    Antwerpen
    cPanel Access Level:
    Root Administrator
    I found this in one of my old documents...

    In exim under advanced settings, it rewrites it.

    # Set return-path sender to local domain instead of hostname.
    untrusted_set_sender = *@+local_domains
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    648
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    The best way to solve this issue is to require your users to utilize SMTP authentication when sending out emails. However, you are welcome to implement that custom Exim entry and let us know the outcome.

    Thank you.
     
Loading...

Share This Page