The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

/~username no access?

Discussion in 'General Discussion' started by Final-Solution, Sep 9, 2004.

  1. Final-Solution

    Final-Solution Well-Known Member

    Joined:
    Jul 14, 2002
    Messages:
    92
    Likes Received:
    0
    Trophy Points:
    6
    I got an account set up, but the domain isnt up yet . . I wanted to let the user access his files as ip/~username but haven't had ANY luck getting it to work!

    I've tried turning the mod_userdir on and off a million times in WHM, disabled suexe and manually edit the httpd.conf

    # UserDir: The name of the directory which is appended onto a user's home
    # directory if a ~user request is received.
    #
    <IfModule mod_userdir.c>
    UserDir public_html
    UserDir disabled
    UserDir enabled username
    </IfModule>

    When i try either ip/~username or ip/~username/ it gives HTTP Error 403 - Forbidden . . any ideas? I've searched all over the threads and tried everything I could find . .
     
  2. CCd

    CCd Registered

    Joined:
    Feb 8, 2004
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    I got this message from my host when I just had the same problem:

    You can NOT pre-view your site using the IP method that some hosts allow.
    This has been abused and the reson for it being disabled.
    To preview your site you will need to edit your hosts file.
    Windows: Goto the command prompt: Click start>run>type "command"and press enter.
    Type: notepad c:\windows\system32\drivers\etc\hosts
    Add a line that looks simular to this:
    69.93.22.22 yoururl.com
    69.93.22.22 www.yoururl.com
    Replace the IP with the IP of the server you are on.
    Replace the domain with your domain name.
    Save the file and then goto your domain through the browser.
    Now you can preview it before DNS propogates.

    hope that helps!!
     
  3. Final-Solution

    Final-Solution Well-Known Member

    Joined:
    Jul 14, 2002
    Messages:
    92
    Likes Received:
    0
    Trophy Points:
    6
    Thanks man! You wouldn't happen to have a corresponding file under linux would ya?
     
  4. CCd

    CCd Registered

    Joined:
    Feb 8, 2004
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    no sorry dont know the linix eqiv
    please post it here when u find out - I would also like to know

    FYI
    Soemone PM'ed me on this from the forum and mentioned that
    "That will not work with shared hosting accounts without a dedicated IP"
    BUT, my account in question does not have a fixed IP.... AND I have accounts with other hosts that have sent me ip/~account info...and they were not fixed ip's either

    all the best
     
  5. SarcNBit

    SarcNBit Well-Known Member

    Joined:
    Oct 14, 2003
    Messages:
    1,010
    Likes Received:
    3
    Trophy Points:
    38
    Make sure you have:

    AddModule mod_userdir.c

    and

    <IfModule mod_userdir.c>
    UserDir public_html
    </IfModule>

    in your httpd.conf file.
     
  6. SarcNBit

    SarcNBit Well-Known Member

    Joined:
    Oct 14, 2003
    Messages:
    1,010
    Likes Received:
    3
    Trophy Points:
    38
    /etc/hosts

    You may need to edit your /etc/hosts.conf to get the results you expect
     
  7. maskmoataz

    maskmoataz Member

    Joined:
    Aug 1, 2004
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    hello
    i have same problem but when i enable mod_userdir Protection in whm in Tweak Security it' not work with ip/~username and get Not Found
    The requested URL /~crazy/index.html was not found on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
    but when i not enable it it work fine can any one help me i have check this line
    AddModule mod_userdir.c
    and this line
    <IfModule mod_userdir.c>
    UserDir public_html
    </IfModule>
    in httpd.conf and it's found it so any solve
    thank you
     
    #7 maskmoataz, Dec 15, 2005
    Last edited: Dec 15, 2005
Loading...

Share This Page