The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Users uanble to send mail via Outlook

Discussion in 'E-mail Discussions' started by Boboss, Oct 19, 2006.

  1. Boboss

    Boboss Active Member

    Joined:
    May 26, 2003
    Messages:
    28
    Likes Received:
    0
    Trophy Points:
    1
    All users newly moved onto my (new) server, including in our own tests, have reported being unable to send email using Outlook or any other mail client.

    They can receive mail into Outlook, but cannot send at all.

    Despite the info provided in Cpanel for configuring Outlook Express, nothing works. My users did follow the instructions about using the format "user+domain.com", with incoming and outgoing mail servers being something like "mail.domain.com".

    What is preventing mail from being sent this way? All these accounts were just moved. They all were working fine in their previous server.

    the error message I get from Thunderbird is something like this:

    ---------
    The messsage could not be sent because connecting to SMTP server domain.com failed. The server may be unavailable or refusing SMTP connections.
    ----------------

    Any idea?
     
  2. Lyttek

    Lyttek Well-Known Member

    Joined:
    Jan 2, 2004
    Messages:
    770
    Likes Received:
    3
    Trophy Points:
    18
    What happens if you telnet to the server on port 25? Does it connect or timeout? What about port 110?

    If it works on port 110 but not 25, it's most likely the ISP blocking it. Other possibilities:

    firewall blocking it
    smtp server not running, or running on wrong port

    Are you running a second copy on another port? If so, can you telnet to that?
     
  3. Boboss

    Boboss Active Member

    Joined:
    May 26, 2003
    Messages:
    28
    Likes Received:
    0
    Trophy Points:
    1
    You have a code that would allow me to conduct these tests? I do not sue telnet, but SSH.

    What code do I need to test the connection?

    Thanks.
     
  4. WestBend

    WestBend Well-Known Member

    Joined:
    Oct 12, 2003
    Messages:
    173
    Likes Received:
    0
    Trophy Points:
    16
    open a command prompt in windows.
    type

    telnet mailserver.address 25

    see what happens.

    are you running a copy of exim on port 26 as well?

    if so..

    try telnet mailserver.address 26

    you should see something like :

    220-something.com ESMTP Exim 4.52 #1 Fri, 20 Oct 2006 00:58:42 -0500

    if you do then type quit

    if you dont get anything then check your firewall settings.
     
  5. Boboss

    Boboss Active Member

    Joined:
    May 26, 2003
    Messages:
    28
    Likes Received:
    0
    Trophy Points:
    1

    This is what I see when I type your commands:

    root@host [~]# telnet mail.domain.com 25
    Trying 74.X.X.X...
    Connected to mail.domain.com (74.X.X.X).
    Escape character is '^]'.
    220-host.hostname.com ESMTP Exim 4.52 #1 Fri, 20 Oct 2006 09:42:29 -0400
    220-We do not authorize the use of this system to transport unsolicited,
    220 and/or bulk e-mail.


    This is strange. This would suggest the connection is being established, right?

    So why are mail clients (Outlook Express, Thunderbird) not connecting to send email, but only receiving?
     
    #5 Boboss, Oct 20, 2006
    Last edited: Oct 20, 2006
  6. Lyttek

    Lyttek Well-Known Member

    Joined:
    Jan 2, 2004
    Messages:
    770
    Likes Received:
    3
    Trophy Points:
    18
    Yup, it's connecting.

    Now, did you / can you run the same test on a machine that isn't sending mail?
     
  7. Boboss

    Boboss Active Member

    Joined:
    May 26, 2003
    Messages:
    28
    Likes Received:
    0
    Trophy Points:
    1
    What machine exatly would this be? My personal machine at home/office or a server?

    or do you mean the machine from which I connect to the mail server, whihc means the machine where I have Thunderbird installed and from which I am trying to connect to the mailserver to send emails? This is what I was doing from SSH.

    However, I do have a firewall at home and on the server. Do you think my home firewall could prevent access? But then again, I have an Ensim server where everything is working perfectly, despite my personnal computer's firewall. So, the issue is more with the Cpanel/WHM server I assume.
     
  8. Lyttek

    Lyttek Well-Known Member

    Joined:
    Jan 2, 2004
    Messages:
    770
    Likes Received:
    3
    Trophy Points:
    18
    Well, just so we cover all the bases including the basics....

    If your cPanel server has an IP of 12.34.56.78 and a DNS A record of mail.domain.com pointing to that IP address, in a normal client setup mail.domain.com would be the incoming server name.

    The outgoing server, in many cases, would be specified by the ISP to which the client computer connects. Standard port for smtp is 25. Now then, many ISPs will block traffic on port 25 *unless* that traffic is specifically headed to *their* smtp server.

    This means that if the ISP smtp server is mail.isp.com, you'll have two different servers listed in the email client settings: Incoming=mail.domain.com, outgoing=mail.isp.com

    Now let's say you don't want to use the ISP smtp server. On your cPanel box you can run a second copy of your smtp service on a port other than 25... we'll use 26 for this example.

    With that, you can setup your email client to use mail.domain.com as both incoming and outgoing servers. BUT, you have to go into the advanced properties for the outgoing server and change the port number to 26.

    So now for some testing.

    On the computer that isn't sending email you open a command prompt and issue the following command:

    Code:
    telnet mail.domain.com 25
    If it connects, your ISP is NOT blocking port 25 traffic. If it doesn't connect, then you try the following command:

    Code:
    telnet mail.domain.com 26
    Again, you must be running a second smtp server using port 26 for the above to work. (port number can be pretty much anything you want, it's not limited to 26)

    If it connects on port 25 or 26, but you still can't send email, then the most likely cause is that there is a configuration setting that's incorrect in your email client.

    With the above tests you know several things:
    your DNS settings are correct; your server isn't blocking smtp traffic; there's an smtp service actually running on that port

    It's still possible that there is an actual problem with the smtp service itself, but this is least likely of your problems. But if you want to test that as well, the following commands let you actually create an email message via command prompt:

    Code:
    [B]telnet <your mail server> <smtp port>
    helo <your domain name><enter>[/B]
                      
    response should be as follows
    250 OK
    
    [B]mail from: <your Email Address><enter>[/B]
    
    response should be as follows
    250 OK - mail from <your Email address>
    
    [B]rcpt to: <recipient address><enter>[/B]
    
    response should be as follows
    250 OK - Recipient <recipient address>
    
    [B]data<enter>[/B]
    response should be as follows
    354 Send data.  End with CRLF.CRLF
    
    [B]To: <recipient's display name><enter>
    From: <your display name><enter>
    Subject: <Subject field of Email message><enter>
    <Enter you body text><enter><enter> . <enter>[/B]
    
    response should be as follows
    250 OK
    
    [B]quit<enter>[/B]
    If all of that works, then it is definitely your email client.
     
  9. Boboss

    Boboss Active Member

    Joined:
    May 26, 2003
    Messages:
    28
    Likes Received:
    0
    Trophy Points:
    1
    Thanks, Lyttek.

    I went through all your steps.

    But when I got to the "rcpt to:", I got the following error

    -----------

    rcpt to: email@domain.com
    550-(domain.com) [74.XX.XX.XX] is currently not permitted to relay through this
    550-server. Perhaps you have not logged into the pop/imap server in the last 30
    550 minutes or do not have SMTP Authentication turned on in your email client.
    -----------

    Of course, I have SMTP Authentication turned on in both Thunderbird and Outlook Express. But none has worked.
     
  10. 118

    118 Registered

    Joined:
    Dec 2, 2006
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    i have same problem

    i got same error on rcpt to:

    i cant send or received mail
    please help me !!!!!!!!!!!! :( :( :(
     
  11. celliott

    celliott Well-Known Member

    Joined:
    Jan 2, 2006
    Messages:
    460
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    United Kingdom
    One of the most obvious things to try is reinstall exim:

    /scripts/rebuildeximconf
    /scripts/eximup --force

    See if that helps at all.
     
  12. AndyReed

    AndyReed Well-Known Member
    PartnerNOC

    Joined:
    May 29, 2004
    Messages:
    2,222
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Minneapolis, MN
    When an SMTP server performs an action, it will give a three digit code which tells exactly what went on. One of the most common codes is550

    5xx - There was a permanent error, and the requested operation will never be completed.

    That said, 550 error means that the email cannot be sent, either because of an administrative prohibition on the host/email address that the mail is coming from, or because relaying is not allowed. In any case, make sure your DNS zone(s) and NS are correct. Then run:
    /scripts/fixrelayed
    /scripts/fixrndc
     
  13. RTCruiser

    RTCruiser Active Member

    Joined:
    Jun 28, 2006
    Messages:
    36
    Likes Received:
    0
    Trophy Points:
    6
    A couple more things to check:

    Make sure the reverse DNS is set up for your server.

    In each of your clients, use 'Edit DNS zone' to add your server's ns1 and ns2 ip address as an A record. This also helps many ISP's trust your server.
     
  14. Lyttek

    Lyttek Well-Known Member

    Joined:
    Jan 2, 2004
    Messages:
    770
    Likes Received:
    3
    Trophy Points:
    18
    I believe the 550 error in this case is probably a 'pop before smtp' generated message, meaning you should telnet to port 110 first and login, disconnect, then try port 25/26.
     
  15. BraveX

    BraveX Well-Known Member

    Joined:
    Apr 8, 2005
    Messages:
    155
    Likes Received:
    0
    Trophy Points:
    16

    Never heard of doing this. Could you elaborate more?

    thanks,
    BX
     
  16. lloyd_tennison

    lloyd_tennison Well-Known Member

    Joined:
    Mar 12, 2004
    Messages:
    698
    Likes Received:
    1
    Trophy Points:
    18
    It means just as it says - turn on authentication in Outlook in the Mail account settings.

    In Outlook 2003 it is: (similar in other versions)

    Tools | E-mail Accounts | View or Change e-mail accounts | Change | More Settings | Outgoing Server |

    Then Check:

    My Outgoing server requires authentication.

    Then usually:

    Use same settings as my incoming mail server.

    Save all and retry sending. Sometimes you may need to close and reopen Outlook.
     
Loading...

Share This Page