Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

using pcre and modsec with apache 1

Discussion in 'EasyApache' started by 4u123, Feb 24, 2006.

  1. 4u123

    4u123 Well-Known Member
    PartnerNOC

    Joined:
    Jan 2, 2006
    Messages:
    838
    Likes Received:
    14
    Trophy Points:
    168
    I'm wanting to speed up mod security by using pcre. On a test server I've compiled pcre using the default options and installed mod_security using

    /usr/local/apache/bin/apxs -DUSE_PCRE -cia mod_security.c

    Got no errors but apache wont start...

    Cannot load /usr/local/apache/libexec/mod_security.so into server: /usr/local/apache/libexec/mod_security.so: undefined symbol: pcre_compile

    I'm presuming many of you folks have installed this - what did I do wrong ?
    Should I have compiled pcre with different options ?
     
  2. fleksi

    fleksi Well-Known Member

    Joined:
    Sep 17, 2003
    Messages:
    125
    Likes Received:
    0
    Trophy Points:
    166
  3. 4u123

    4u123 Well-Known Member
    PartnerNOC

    Joined:
    Jan 2, 2006
    Messages:
    838
    Likes Received:
    14
    Trophy Points:
    168
    If I could fix this issue by reading the documentation for mod security, I wouldnt have posted on here!

    EDIT......

    OK I eat my words! I loaded pcre after modesc in the apache config by mistake and the documentation DOES mention making sure not to do that. I had read the documentation b4 but your post made me double check.

    Apologies :)
     
    #3 4u123, Feb 25, 2006
    Last edited: Feb 25, 2006
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice