Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Using SMTP with external email client problem

Discussion in 'E-mail Discussion' started by patelchris97, Jan 28, 2019.

  1. patelchris97

    patelchris97 Member

    Joined:
    Jan 27, 2019
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    south africa
    cPanel Access Level:
    Root Administrator
    I am trying to use the SMTP with turbomailer but its getting failed. i have also turn off the option "Require clients to connect with SSL or issue the STARTTLS command before they are allowed to authenticate with the server" and its still giving me error. i disable smtp restriction but nothing work. if i try to send via my whm/cpanel webmail its work fine but cant connect with external email client

    [removed - please attach images directly to thread]

    can anyone give me the solution
     

    Attached Files:

    #1 patelchris97, Jan 28, 2019
    Last edited by a moderator: Jan 29, 2019
  2. cPanelLauren

    cPanelLauren Forums Analyst II Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    6,208
    Likes Received:
    478
    Trophy Points:
    233
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hello @patelchris97


    It sounds like you're attempting to make an SSL connection to the server from the mail client. What ports are you using for incoming/outgoing server?


    Thanks!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. patelchris97

    patelchris97 Member

    Joined:
    Jan 27, 2019
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    south africa
    cPanel Access Level:
    Root Administrator
    i dont think its issue with port, i have tried both port 465/587 but its give me same error. thats problem mostly happens when "Require clients to connect with SSL or issue the STARTTLS command before they are allowed to authenticate with the server" is set to "ON". well this time, after installing whm in new server and turn that off, i still got the error but via webmail its work fine. i have installed whm in 2 different new server and that error still happen.
     
  4. cPanelLauren

    cPanelLauren Forums Analyst II Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    6,208
    Likes Received:
    478
    Trophy Points:
    233
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hi @patelchris97


    Turning the require SSL/STARTTLS before an account can authenticate off is not going to stop the client from attempting to make a connection over SSL and right now based on that screenshot you're showing me you're attempting to make an SSL connection to the server. I'd wager that the client is using an out of date SSL protocol that the server does not support as well. You'd be able to see this in the exim logs at
    Code:
    /var/log/exim_mainlog
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. patelchris97

    patelchris97 Member

    Joined:
    Jan 27, 2019
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    south africa
    cPanel Access Level:
    Root Administrator
    [root@vm-francmay-105903 ~]# /var/log/exim_mainlog
    -bash: /var/log/exim_mainlog: Permission denied
    [root@vm-francmay-105903 ~]# /var/log/exim_mainlog
    -bash: /var/log/exim_mainlog: Permission denied
     
  6. cPanelLauren

    cPanelLauren Forums Analyst II Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    6,208
    Likes Received:
    478
    Trophy Points:
    233
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hello @patelchris97


    I just gave you the location of the exim_mainlog just running that won't get you any output. You might try something like the following:

    Code:
    grep "email@domain.tld" /var/log/exim_mainlog
    Where email@domain.tld is the email address you're looking for
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. patelchris97

    patelchris97 Member

    Joined:
    Jan 27, 2019
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    south africa
    cPanel Access Level:
    Root Administrator
    i installed whm in another server and smtp work with external client in 24hours. then after i reboot server to apply update
    am getting "smtpconnecterror 421"
     

    Attached Files:

  8. cPanelLauren

    cPanelLauren Forums Analyst II Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    6,208
    Likes Received:
    478
    Trophy Points:
    233
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hi @patelchris97

    What is output in the exim logs for that transaction?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice