The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Using unique option prefix 'pass' is error-prone and can break in the future.

Discussion in 'Database Discussions' started by EneTar, May 17, 2016.

  1. EneTar

    EneTar Well-Known Member

    Joined:
    Dec 19, 2015
    Messages:
    51
    Likes Received:
    1
    Trophy Points:
    8
    Location:
    Greece
    cPanel Access Level:
    Root Administrator
    I have successfully upgraded from MySQL to MariaDB 10.1 After the upgrade I get an this email from the server.

    I have tried /scripts/repairmysqllist but the issue remains. What am I supposed to do?
     
  2. ssfred

    ssfred Well-Known Member

    Joined:
    Jan 6, 2012
    Messages:
    62
    Likes Received:
    2
    Trophy Points:
    8
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello :)

    Please check if your /root/.my.cnf file uses the parameter "pass". If so change it to the full parameter "password" and try.
     
    rpvw and EneTar like this.
  3. EneTar

    EneTar Well-Known Member

    Joined:
    Dec 19, 2015
    Messages:
    51
    Likes Received:
    1
    Trophy Points:
    8
    Location:
    Greece
    cPanel Access Level:
    Root Administrator
    Thank you for your answer I just did what you said, I think it works! When repairing a database I don't get those "pass" warnings
     
  4. EneTar

    EneTar Well-Known Member

    Joined:
    Dec 19, 2015
    Messages:
    51
    Likes Received:
    1
    Trophy Points:
    8
    Location:
    Greece
    cPanel Access Level:
    Root Administrator
    Unfortunately I got the same email today from my server

    Then I went again at /root/.my.cnf and the values was changed back to pass= instead of password. In the meantime I know that the server has been restarted and I guess it changes the value each time it restarts. So what should I do to keep the value password instead of pass?
     
  5. rpvw

    rpvw Well-Known Member

    Joined:
    Jul 18, 2013
    Messages:
    123
    Likes Received:
    36
    Trophy Points:
    28
    Location:
    Spain
    cPanel Access Level:
    Root Administrator
    I have no idea if this might work - but you might want to try looking at editing in WHM

    Home » SQL Services » Manage MySQL® Profiles

    Perhaps use the existing password for the root profile that is in the /root/.my.cnf file, and see if the my.cnf is regenerated with the password tag instead of pass
     
    #5 rpvw, May 19, 2016
    Last edited by a moderator: May 19, 2016
  6. EneTar

    EneTar Well-Known Member

    Joined:
    Dec 19, 2015
    Messages:
    51
    Likes Received:
    1
    Trophy Points:
    8
    Location:
    Greece
    cPanel Access Level:
    Root Administrator
    There is a profile active there but the file .my.cnf every time is regenerated with the word "pass" instead of "password"
     
  7. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello,

    Could you verify the specific action you are taking to regenerate the /root/.my.cnf file? Also, please post the output from the following command:

    Code:
    cat /usr/local/cpanel/version
    Thank you.
     
  8. EneTar

    EneTar Well-Known Member

    Joined:
    Dec 19, 2015
    Messages:
    51
    Likes Received:
    1
    Trophy Points:
    8
    Location:
    Greece
    cPanel Access Level:
    Root Administrator
    I don't know how this file is regenerated but every time I edit the file manually and I change the word "pass" to "password" then after a day or two I open the file and the word is again "pass" instead of "password".
    This morning I set the permissions of the file to 400 and I'm going to check again tomorrow or the day after.

    My WHM, Cpanel version is 11.56.0.22

    Do you have anything else to suggest?
     
  9. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    I've been unable to reproduce this issue on a test system. Feel free to open a support ticket using the link in my signature so we can take a closer look. You can post the ticket number here so we can update this thread with the outcome.

    Thank you.
     
  10. EneTar

    EneTar Well-Known Member

    Joined:
    Dec 19, 2015
    Messages:
    51
    Likes Received:
    1
    Trophy Points:
    8
    Location:
    Greece
    cPanel Access Level:
    Root Administrator
    It appeared to be some processes running to update mysql versions
    This fixed it, or at least for now the parameter "pass" hasn't changed yet
    Code:
    # /scripts/update_local_rpm_versions --edit target_settings.MySQL50 uninstalled
    # /scripts/update_local_rpm_versions --edit target_settings.MySQL51 uninstalled
    # /scripts/update_local_rpm_versions --edit target_settings.MySQL55 uninstalled
    # /scripts/update_local_rpm_versions --edit target_settings.MySQL56 uninstalled
     
  11. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
Loading...

Share This Page