The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Using webmail in safari on an ipad over 3g causes "Your ip address has changed" errors

Discussion in 'Security' started by tommcquarrie, Jan 20, 2014.

  1. tommcquarrie

    tommcquarrie Registered

    Joined:
    Nov 28, 2013
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hi there,

    Just hoping there's a work around for this issue. Spent ages on google, couldn't find anything, so trying to use as many keywords as possible so others with the same issue can find this thread.

    If you're on an ipad, using safari, on 3g, you can't use cpanel webmail without Cookie IP Validation off. Every request you make to webmail kicks you out with the standard "Your ip address has changed" error. If you're on wifi, or if you're using chrome on the ipad via 3g, it works fine.

    Strangely, the ip address isn't actually changing. Running some tests echoing out $_SERVER from a test server, REMOTE_ADDR doesn't change from one request to the next. What DOES change is the port number at REMOTE_PORT. So I'm guessing when cpanel checks for an ip address change, they're actually checking a combination of the ip address and port.

    I'd really prefer not to turn off Cookie IP Validation, but getting a fair few complaints with the current implementation. I'm wondering if it's possible to change the routine at all to check the ip address, but not the port number? Is there some template file I could modify to achieve this? Or would this also be quite dangerous and I'd be better off leaving the port number detection in place?

    Any assistance would be greatly appreciated.
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,776
    Likes Received:
    663
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Do you notice any change in the results if you access webmail directly over the port 2095/2096 instead of through webmail.domain.com?

    Thank you.
     
  3. tommcquarrie

    tommcquarrie Registered

    Joined:
    Nov 28, 2013
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Thanks for the prompt reply. We redirect all users directly to mailserver.domain.com:2096. We force the use of the ssl connection.

    I just temporarily disabled "require ssl" and logged in via port 2095, and the issue still persists, so from what I can tell it's definitely caused by safari connecting via a variety of local port numbers when using 3g.

    I'm wondering though, if we're requiring ssl for all connections, perhaps the 'same ip address' restriction is overkill, considering (from what I'm aware) it would be impossible to highjack a login using ssl anyway. In your opinion, is there any security benefit to having both these options enabled at the same time?
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,776
    Likes Received:
    663
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    I was unable to reproduce this issue using Safari on an iPad. Feel free to submit a support ticket using the link in my signature so we can take a closer look. You can post the ticket number here so we can update this thread with the outcome.

    Thank you.
     
  5. tommcquarrie

    tommcquarrie Registered

    Joined:
    Nov 28, 2013
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    I originally posted that it worked in chrome. That must have been a fluke occurrence, it's not working in chrome either. Looking into it further, it's just an intermittent issue, across all browsers, when connecting over 3g, with the ip address changing on each request, which will be controlled by the cellular provider. So the only solution for enabling webmail access over 3g in these situations would be to disable the ip check.

    Going back to my other question, if we have ssl connections as mandatory, is there still a risk of highjacking someone's login, to the point where the ip address check is still necessary?
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,776
    Likes Received:
    663
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Using SSL will not necessarily prevent any CSRF attack. Utilizing cookie IP validation adds an extra layer of security. It's up to the administrator to determine the right balance of security and usability that best suites their individual requirements.

    Thank you.
     
Loading...

Share This Page