The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

/usr/bin/perl not properly linked to /usr/local/bin/perl

Discussion in 'General Discussion' started by CanSpace, Nov 25, 2011.

  1. CanSpace

    CanSpace Member

    Joined:
    Nov 25, 2011
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    www.canspace.ca
    cPanel Access Level:
    DataCenter Provider
    Whenever we enable the "Perl Module Magic User Loader" on our machine (The Magic User Loader modifies the system copy of perl so that users will be able to include modules that they install without having to modify their scripts.), we get an email every night with the following contents:

    However when we follow these instructions, according to WHM the "Perl Module Magic User Loader" is then DISABLED.

    How do we resolve this problem while keeping the magic loader enabled at the same time?

    Also it doesn't seem to be possible to install perl modules from within cPanel... the installation just does nothing.
     
  2. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Are you certain there is a /usr/local/bin/perl on the system that exists? If there isn't and it is a symlink, then the symlink from /usr/bin/perl will be a non-working symlink. You'd need to copy /usr/bin/perl to /usr/local/bin/perl replacing the existing /usr/local/bin/perl if it is a symlink, then symlink /usr/bin/perl to it.

    Could you provide the following details from ls -lah on both files?

    Code:
    ls -lah /usr/bin/perl /usr/local/bin/perl
    Thanks!
     
  3. CanSpace

    CanSpace Member

    Joined:
    Nov 25, 2011
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    www.canspace.ca
    cPanel Access Level:
    DataCenter Provider
    Yes the file did exist. As soon as I deleted (and backed up) the perl in /usr/bin and then linked it to the one in /usr/bin/perl WHM reported that the "Magic User Loader" was disabled.

    Then when I click "Enable", WHM deletes the symlink (and I'll start getting the error messages again):

    [/usr/bin]# ls -lah /usr/bin/perl /usr/local/bin/perl
    -rwxr-xr-x 1 root root 4.7K Nov 27 15:33 /usr/bin/perl*
    -rwxr-xr-x 2 root root 17K Nov 16 20:50 /usr/local/bin/perl*

    This happens on two completely separate systems I have. Seems like a bug?
     
  4. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    If you believe this might be an issue warranting a case, please visit http://go.cpanel.net/bugs to report this to us. Thanks!
     
  5. CanSpace

    CanSpace Member

    Joined:
    Nov 25, 2011
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    www.canspace.ca
    cPanel Access Level:
    DataCenter Provider
    FYI turns out this was indeed a bug. I've been told they are working on a fix.
     
Loading...

Share This Page