Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

/usr/local/bin/php & /usr/bin/php

Discussion in 'General Discussion' started by ispro, Oct 11, 2004.

  1. ispro

    ispro Well-Known Member

    Joined:
    Apr 8, 2004
    Messages:
    628
    Likes Received:
    1
    Trophy Points:
    168
    I've compiled apache with php_suexec support.

    Well, then I realized that when I run php in the shell it shows be the old version instead.

    I've find that there are three places where php could be located:
    1) /usr/local/bin/php
    2) /usr/bin/php
    3) /usr/local/cpanel/3rdparty/bin/php

    1st seems useless... how to avoid of it? Or I will be in need of reinstalling php there as well?..

    2nd is used by apache with php_suexec (at least the php used there has /usr prefix).
    This php was compiled by makecpphp which was adjusted to have own configure options and /usr prefix.

    3rd is used by apache for cPanel php (!!) E.g. when I run Horde I got another version of php!

    So I'm a little confused... I've had installed php with /usr/local/cpanel/3rdparty prefix as well just for cPanel to use it for webmails!

    Conclusion:
    we was insisted to install php in /usr for our customers to use latest php and do the same for /usr/local/cpanel/3rdparty for cPanel itself.

    Could anyone explain it? (too many php places IN USE are there...)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice