Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

UTF-8 problems/auto-responders

Discussion in 'General Discussion' started by Rbrt, May 15, 2008.

  1. Rbrt

    Rbrt Member

    Joined:
    May 15, 2008
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    51
    (We are using 11.18.6-RELEASE_24255.)

    Our users set auto-responders in cPanel which frequently contain French characters. Unfortunately, auto-responses have been turning up with broken characters (like the famous �) instead of é or ù (just for example). If I go to "Add Auto-responder" and fill in the fields, I note that the Character Set is set to UTF-8 (which is as it should be, as far as I'm concerned).

    But, if I change the Character Set to us-ascii or iso-8859-1 the auto-responses turn up with French characters intact. Why is UTF-8 the set that breaks French characters?

    I saw a thread about a bug in UTF-8 support for cPanel but that looked like it referred to an earlier version. I also note that a View Source on the cPanel page shows that it is served up in iso-8859-1, so I'm wondering if there is a mismatch within cPanel or somewhere else on the server (Apache? Mail spooler? I'm not knowledgeable enough to know if this would be an issue). Is there a setting I can change in cPanel?

    I would like to avoid having our users manually change the Character Set each time they set an auto-responder. I'd also like to make UTF-8 work, since it's the one we want to use.
     
  2. xidica

    xidica Well-Known Member

    Joined:
    Apr 21, 2005
    Messages:
    63
    Likes Received:
    0
    Trophy Points:
    156
    Location:
    Texas
    I'd like to see some progress in this area as well. :|
     
  3. Rbrt

    Rbrt Member

    Joined:
    May 15, 2008
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    51
    It gets stranger. I've discovered that Apple Mail is actually capable of rendering these auto-responder messages correctly. But if I look at the same exact message in a Gmail web interface (or any of the other web interfaces I've tested) the French characters appear broken.

    So if everyone used Apple Mail this wouldn't be a problem! :confused:
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice