The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

valiases / vdomainaliases

Discussion in 'General Discussion' started by 4UHChris, Oct 10, 2007.

  1. 4UHChris

    4UHChris Member

    Joined:
    Sep 30, 2007
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    If a customer creates an email forwarder, it is written to /etc/valiases/domain

    If a customer creates a domain forwarder, it is written to /etc/vdomainaliases/domain

    I have one customer who has a domain forwarder set as follows...


    domain1.com > domain2.com


    If I look in the default email settings - for domain1 it is set to catch-all to the user account mailbox.

    So the domain forwarder doesnt work. If you send email to domain1 it is not forwarded to domain2. Instead it goes into the catch-all mailbox

    What I'm trying to figure out is why the domain forwarding has not overwridden the default setting. If I set it to :fail: it will bounce so I'm confused as to how this should work.

    Currently valiases says "*: username" and vdomainaliases says "domain1.com: domain2.com"

    When working correctly, should cpanel remove the "*: username" entry from /etc/valiases/domain ?
     
  2. 4UHChris

    4UHChris Member

    Joined:
    Sep 30, 2007
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    I have looked at the valiases and vdomainaliases files for an account on a server where email domain forwarding is working correctly.

    The entries in the files are the same as mentioned for the domain above that is not working.

    I have run /scripts/fixvialiases - no joy.

    Can anyone suggest why the email domain forwarding is not working ?
     

Share This Page