/var/log/journal is very large

Operating System & Version
Centos 7.9.2009
cPanel & WHM Version
11.102.0

jimlongo

Well-Known Member
Mar 20, 2008
263
22
68
Ran out of disk space doing a backup.
Unusual.

First thing I find is that /var/log/journal has grown to 3.2GB. (also 3.8G ./apache2)

Checked WHM and rotation size is 300MB. Also notice that "journal" is not available as a choice in the Log Rotation Configuration.

I can manually delete the files of course, but figure there must be an underlying reason why.
 
Last edited:

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
12,499
1,971
363
cPanel Access Level
Root Administrator
Hey there! There is a SystemMaxUse parameter inside /etc/systemd/journald.conf - can you adjust that value? By default, on the systems I checked just now, it is blank.

Some more details on this configuration here:

 

jimlongo

Well-Known Member
Mar 20, 2008
263
22
68
Thanks. I was able to set it to

SystemMaxUse=400MB

Haven't seen the effect yet. Can I kick that cron (not sure which one is responsible)?
 

quietFinn

Well-Known Member
Feb 4, 2006
1,696
352
438
Finland
cPanel Access Level
Root Administrator
Maybe this helps:
 

jimlongo

Well-Known Member
Mar 20, 2008
263
22
68
Maybe this helps:
Thanks, that did help … just to note —rotate didn't work on my system, but vacuum did.

[email protected] [~]# sudo journalctl --rotate
journalctl: unrecognized option '--rotate'
 
  • Like
Reactions: cPRex