The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Various Problems

Discussion in 'General Discussion' started by Andrew87, Jul 28, 2005.

  1. Andrew87

    Andrew87 Member

    Joined:
    May 14, 2005
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    Hi, I recently got hold of a dedicated server and am having a few problems. Earlier today I tried to compile Apache with PHP suEXEC, there seemed to be no errors and everything I tried connecting to a website using PHP hosted on the server I got a 500 Internal Server Error. Eventually I just rebuilt Apache without PHP suEXEC and everything seemed to work fine.

    The main problems started after I attempted to upgrade to the current version of cPanel. When I did so I could not find an icon to Fantastico anymore, I also noticed that parked domains was showing 1/unlimited on all my accounts; when I tried to remove these parked domains I got an error message saying unable to park main domain. I thought maybe these were due to bugs in the current version of cpanel so I downgraded to the release version. I also removed all instances of Fantastico as I decided a reinstall at this point would be best.

    cPanel still reported 1/unlimited parked domains on all accounts so I reorganised my httpd.conf file which appeared to have sorted the problem.

    In WHM, I had previously set up a parked domain, domainy.com is parked to domainx.com; however, I can find no way to delete this. I tried clearing the DNS Zone for the parked domain and I checked my httpd.conf file to check that it does not exist there, it doesn't. However, if I goto 'Park or Point a Domain' under 'DNS Functions' the parked domain is still there. How do I remove this domain?

    Another problem which seems to be directly related is that when I make any sort of domain modifications, e.g. add a new account, park a domain etc, my httpd.conf files permissions get changed to 600 and when I login to cPanel I get the error 'Fatal Error! Unable to open httpd config file /usr/local/apache/conf/httpd.conf!' under subdomains and there is no IP address displayed for the server. How can I fix this?

    Finally, my account is displaying usage of over 500mb when du shows that it is infact only 800kb, is there any way to fix this?

    I know there's many problems there but they've all seem to have occured within the last few hours, prior to this everything was fine.

    I appreciate any help you can give, thanks :)
     
  2. kaosent

    kaosent Active Member

    Joined:
    Jul 12, 2005
    Messages:
    44
    Likes Received:
    0
    Trophy Points:
    6
    I just posted a response to another thread regarding 500 server errors that may have been caused by phpsuexec.

    I use it, and had the same problems (500 s.e.) with nearly every script. I read this great guide posted here: http://forums.cpanel.net/showthread.php?t=13119&highlight=phpsuexec
    and set up the permissions and ownership as it described... worked perfect. That should solve at least your first issue :) .
     
  3. Andrew87

    Andrew87 Member

    Joined:
    May 14, 2005
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    Thanks for your reply, I'll be sure to try that after I get everything working properly.
     
Loading...

Share This Page