ianpeace1980

Member
Jul 17, 2010
5
0
51
hey guys i am having a bit of trouble running forum software specifically vbulletin, now i dont know if this problem affects other software but when i try to load up index.php or any other file in there it appears a blank page, i have also looked inside the error logs and see the following

[Sat Jul 17 22:02:02 2010] [error] [client 90.194.58.238] Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 28579841 bytes) in /home/clanwarc/public_html/forum/includes/class_core.php on line 3243, referer: Index of /~clanwarc
[Sat Jul 17 22:01:59 2010] [error] [client 90.194.58.238] Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 28579841 bytes) in /home/clanwarc/public_html/forum/includes/class_core.php on line 3243, referer: Index of /~clanwarc
[Sat Jul 17 21:56:07 2010] [error] [client 90.194.58.238] Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 129239041 bytes) in /home/clanwarc/public_html/forum/includes/class_core.php on line 3243, referer: Index of /~clanwarc

i have contacted my own support service but they can not seem to fix the problem, but after looking thru google it could be something to do with the server api being set to CGI instead of apache but i dont know, Is there any chance that you guys have had this problem from anyone else before and could help me out?
 

ianpeace1980

Member
Jul 17, 2010
5
0
51
i should also state i have upped the memory usage from 32M to 64M to 128M to 2048M which at that point came back with error 500
 

Miraenda

Well-Known Member
Jul 28, 2004
243
6
168
Coralville, Iowa USA
cPanel Access Level
Root Administrator
If your provider handles the httpd.conf on the machine, ask them if they have set RLimitMEM for it. You might well be hitting the RLimitMEM limit on the machine with your index.php
 

ianpeace1980

Member
Jul 17, 2010
5
0
51
thing is in the php.ini i set the mem limit as i said in my post and everytime i get the error it it says the error then the limit i have set in php.ini if ya know what i mean but i will ask
 

ianpeace1980

Member
Jul 17, 2010
5
0
51
ok here is what they replied to me

Yes, we have set the RLimitMEM in the httpd configuration file.

--------
[email protected] [~]# grep -i RLimitMEM /usr/local/apache/conf/httpd.conf
RLimitMEM 929926826
[email protected] [~]#
--------

We are sorry to say that it is not possible to make modifications in global configuration file values of a shared server. Please contact your developer and check any alternative methods for this.
anything else i can do?
 

Miraenda

Well-Known Member
Jul 28, 2004
243
6
168
Coralville, Iowa USA
cPanel Access Level
Root Administrator
Is your vBulletin configured with extra mods? You could try disabling some of them and tweaking it to take less memory on the index.php page. You may want to post on vBulletin's forum to ask for optimal settings for reduced memory usage.
 

ianpeace1980

Member
Jul 17, 2010
5
0
51
something tells me that wont work either because i tried installing from scratch just the basic vbulletin and it wont work