The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Very annoying DNS bug

Discussion in 'Bind / DNS / Nameserver Issues' started by jandafields, Nov 17, 2011.

Thread Status:
Not open for further replies.
  1. jandafields

    jandafields Well-Known Member

    May 6, 2004
    Likes Received:
    Trophy Points:
    cPanel Access Level:
    Root Administrator
    WHM 11.30.5 (build 2)

    Here is a very annoying dns bug:

    Assuming my IP is

    Edit DNS:

    mail A

    Do something NOT inside dns (I'm not sure exactly what, possibly change site IP or something because it seems to only affect sites with dedicated IP address).

    Then, BY ITSELF, the dns changes to this:

    mail CNAME

    Which, of course, completely breaks connection for anyone using and I have no idea that it changed until customers call with complaints.

    Also, after awhile, the TXT of a domain dns looks like this:

    "v=spf1 ip4: ip4: ip4: ?all"

    Notice that it keeps adding the SAME ip address over and over and over.

    One good question is this:
    What cPanel function changes the MAIL subdomain to a CNAME? That, or something that calls that, is probably where the bug is.
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Apr 11, 2011
    Likes Received:
    Trophy Points:
    cPanel Access Level:
    Root Administrator
    Hello :)

    Bug reports are handled exclusively via our internal bug reporting system. Please open a bug report for this using the following URL:

    Submit A Bug Report

    I encourage anyone else experiencing this issue to also submit a report because the more reports we get, the higher the priority this issue will receive.

    Thank you.
Thread Status:
Not open for further replies.

Share This Page