The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

very heavy load from dnsadmin-ssl

Discussion in 'Bind / DNS / Nameserver Issues' started by bejbi, Sep 23, 2008.

  1. bejbi

    bejbi Well-Known Member

    Joined:
    Jan 20, 2006
    Messages:
    75
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Czestochowa, Poland
    cPanel Access Level:
    DataCenter Provider
    Hi,

    I have on my hosting server high load about 2,9-3,9

    The server is xeon-quad and 4GB of ram (server board and so on ...)

    I can see in top of processes:

    Top Process %CPU 61.0 /usr/local/cpanel/whostmgr/bin/dnsadmin-ssl

    Top Process %CPU 33.0 dnsadmin - RECONFIGBIND - J_eXmSE1cyncteXd3m6jys_9mMyQEM (MASTER)

    Top Process %CPU 32.0 dnsadmin - RECONFIGBIND - v0Ip0bJqJH44VUsRIDwuc0CPNHDlJ (MASTER)

    Should be dnsadmin so processor-hungry ?

    I have about 300 domain on this machine, and two separate dns-only servers. The domain are changing very rarely ... when the process is running there is no dns change ...

    What is the problem with those processes ? or is it ok with cpanel ?

    Wojtek
     
  2. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,458
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    What is your full cPanel version number?

    How long do those processes run?
     
  3. Cristi4n

    Cristi4n Well-Known Member
    PartnerNOC

    Joined:
    Jul 2, 2006
    Messages:
    73
    Likes Received:
    0
    Trophy Points:
    6
    I am experiencing the same problems.
    WHM 11.23.2 cPanel 11.23.6-C27648

    I have disabled the use of compiled dnsadmin and still no results.

    Please advise.

    Thank you!
     
  4. noimad1

    noimad1 Well-Known Member

    Joined:
    Mar 27, 2003
    Messages:
    627
    Likes Received:
    0
    Trophy Points:
    16
    I too am now having this problem. The processes only seem to run 2-3 minutes before a new one is spawned. They are just sitting there eating up the processor.
     
  5. noimad1

    noimad1 Well-Known Member

    Joined:
    Mar 27, 2003
    Messages:
    627
    Likes Received:
    0
    Trophy Points:
    16
    I found a process called "dnsque". I killed that process and it stopped the dnsadmin-ssl processes.

    Then the dnsque process restarted and the dnsadmin-ssl processes came back. So that is the process that is spawning them, now we just need to figure out why it spawning so many non-stop.
     
    #5 noimad1, Sep 30, 2008
    Last edited: Sep 30, 2008
  6. noimad1

    noimad1 Well-Known Member

    Joined:
    Mar 27, 2003
    Messages:
    627
    Likes Received:
    0
    Trophy Points:
    16
    Ok, this seemed to work for me. Some advice from Chirpy on an old thread:

    Clear out these two folders:

    /var/cpanel/clusterqueue/requests
    /var/cpanel/clusterqueue/retry


    I did that and voila, no more dnsadmin-ssl processes
     
  7. Cristi4n

    Cristi4n Well-Known Member
    PartnerNOC

    Joined:
    Jul 2, 2006
    Messages:
    73
    Likes Received:
    0
    Trophy Points:
    6
    Thank you !
     
  8. Cristi4n

    Cristi4n Well-Known Member
    PartnerNOC

    Joined:
    Jul 2, 2006
    Messages:
    73
    Likes Received:
    0
    Trophy Points:
    6
    well, it works for a few minutes/hours but it starts again.
    I am not sure yet as I do not have time to check, but can it be because I have very small ttl-s to a lot of dns zones ?
     
  9. Cristi4n

    Cristi4n Well-Known Member
    PartnerNOC

    Joined:
    Jul 2, 2006
    Messages:
    73
    Likes Received:
    0
    Trophy Points:
    6
    OK, so now I have WHM accelerated (WHM Current tree) and instead of one dnsadmin-ssl killing my CPU I have 4-5 processes doing that now. If anyone knows a solution to this except the one above please let me know.
    Thank you!
     
  10. silversurfer

    silversurfer Well-Known Member

    Joined:
    Dec 29, 2002
    Messages:
    274
    Likes Received:
    0
    Trophy Points:
    18
    Login to WHM

    Tweak Settings -> Tick "Disable use of compiled dnsadmin."

    It is supposedly slower but will resolve the resource issue you noticed.
     
  11. Cristi4n

    Cristi4n Well-Known Member
    PartnerNOC

    Joined:
    Jul 2, 2006
    Messages:
    73
    Likes Received:
    0
    Trophy Points:
    6
    Thank you for the reply.
    I did that but then I had dnsadmin processes killing the CPU.
    I also found some DNS zones with a Serial Number out of range (something like 2008110107003 which is not ok) and fixed them.
    Will wait and see what happends, until now, after fixing the zones, everything seems ok. If the problem still persists I may add a ticket and post the solution here.
     
  12. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    I would suggest opening a ticket @ https://tickets.cpanel.net/submit/
     
Loading...

Share This Page