Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Very Slow VPS: Disk Seems Fast

Discussion in 'CloudLinux' started by TCB13, Jul 18, 2015.

  1. TCB13

    TCB13 Well-Known Member

    Joined:
    Jul 25, 2014
    Messages:
    62
    Likes Received:
    1
    Trophy Points:
    8
    cPanel Access Level:
    Root Administrator
    Hello,

    I've been trying to solve an issue at my VPS. The VPS runs WHM optimized with CL and has 3 x 2.5 Ghz CPU cores. A total of 6 GB of RAM + 1 of Swap.
    My load averages are something like: 0.19 0.13 0.11.

    I tested the HD and got this great result:

    Code:
    [~]# dd if=/dev/zero of=test bs=64k count=16k conv=fdatasync
    16384+0 registos dentro
    16384+0 registos fora
    1073741824 bytes (1,1 GB) copiados, 2,89149 s, 371 MB/s
    However all my websites take about 4 to 5s to open, I'm on a optic fiber internet and I don't have any issues with other websites.

    Here is my Apache status:

    Code:
    Current Time: Saturday, 18-Jul-2015 17:52:34 CEST
    Restart Time: Sunday, 21-Jun-2015 16:54:32 CEST
    Parent Server Config. Generation: 41
    Parent Server MPM Generation: 40
    Server uptime: 27 days 58 minutes 2 seconds
    Server load: 0.09 0.11 0.09
    Total accesses: 8446099 - Total Traffic: 389.1 GB
    CPU Usage: u509.92 s496.77 cu.7 cs.5 - .0431% CPU load
    3.62 requests/sec - 174.6 kB/second - 48.3 kB/request
    8 requests currently being processed, 53 idle workers
    I enabled OPCache and I noticed that as soon as a website is on cache, it opens instantaneously, however if the cache is disabled it takes 4-5 seconds.

    I notice this performance issues with all websites, most of them are simple Wordpress installations without plugins or anything that could actually cause real issues.

    How can I find the cause of this issue? And fix it? It looks like the I/O performance is good and apache has enough workers to take care of things, however it doesn't work fine.

    Thank you.
     
    #1 TCB13, Jul 18, 2015
    Last edited: Jul 18, 2015
  2. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,803
    Likes Received:
    1,898
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. TCB13

    TCB13 Well-Known Member

    Joined:
    Jul 25, 2014
    Messages:
    62
    Likes Received:
    1
    Trophy Points:
    8
    cPanel Access Level:
    Root Administrator
    Well I've done that in the past. I increased my I/O limits on LVE and now everything seems to work fine.

    Apparently my I/O limits were to low to handle wordpress.
     
  4. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,803
    Likes Received:
    1,898
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    I'm happy to see the issue is now resolved. Thank you for updating us with the outcome.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice