The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Very strange API problem

Discussion in 'General Discussion' started by andyf, Aug 15, 2002.

  1. andyf

    andyf Well-Known Member

    Joined:
    Jan 7, 2002
    Messages:
    246
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    UK
    Using the php API for WHM I have it working great, however, when I try to use the php script & WHM API (Accounting.php.inc) from one of our boxes in particular, it just fails to connect. I don't get any response from the API at all, just nothing is returned.

    To ensure it's not my code, I hard coded all the information (hash etc) into a single php file and tested it on all our boxes - and it's just this one machine that it refuses to connect to the WHM API's on the other boxes from. I must add it even refuses to connect to the local machine WHM API.

    However when running from any other box, it connects to all the WHM API's, including the WHM API on the machine the script fails to work from.

    I'm totally lost as this machine is a fresh build and everything else works perfectly fine, plus it doesn't return any errors when using accounting.php.inc - just returns nothing at all.. I can only assume it's something to do with the PHP that is compiled on the machine (unless you know different?) - but what?

    Can anyone suggest anything?

    Thanks,
    Andy.
     
  2. andyf

    andyf Well-Known Member

    Joined:
    Jan 7, 2002
    Messages:
    246
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    UK
    It seems that the latest /scripts/easyapache breaks php curl support and therefore the Accounting.php.inc

    Bug submitted:
    http://web.cpanel.net/bugzilla/show_bug.cgi?id=773

    Andy
     
  3. kwimberl

    kwimberl Well-Known Member

    Joined:
    Aug 13, 2001
    Messages:
    123
    Likes Received:
    0
    Trophy Points:
    16
    It does appear that curl is not installed by default (beginner choice). Just choose advanced and select options yourself. You should do this anyway. :)
     
  4. andyf

    andyf Well-Known Member

    Joined:
    Jan 7, 2002
    Messages:
    246
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    UK
    Doing it as I type :)

    If beginner gives a nice setup its a lot less time consuming to just set it going when you're doing a bunch of machines - also idiot-proof (well almost) as you don't 'miss' an option.

    Would explain why it worked on my dev box tho, as thats always done manually.

    Andy.
     
Loading...

Share This Page