Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Viewing cPanel and Webmail when running through Cloudflare

Discussion in 'General Discussion' started by xman888, Nov 26, 2018.

Tags:
  1. xman888

    xman888 Well-Known Member

    Joined:
    Nov 23, 2005
    Messages:
    61
    Likes Received:
    1
    Trophy Points:
    158
    Hello,

    Wondering if anyone can assist.

    We run quite a few domains through Cloudflare.

    I am looking for the correct set up so that cpanel and webmail can be accessed via sub domain, and those sub domains are running through Cloudflare (so that they can use the Cloudflare SSL feature (so they can be viewed at https)).

    ie. https://webmail.Domain.com.au and https://cpanel.Domain.com.au

    Cloudflare is enabled for the main A record, and the ‘webmail’ and ‘cpanel’ A records

    SSL is set to FLEXIBLE, and ALWAYS USE HTTPS and AUTOMATIC HTTPS REWRITES is enabled.

    When SSL = Flexible, I get the ‘too many redirects’ when viewing https://webmail.Domain.com.au and https://cpanel.Domain.com.au

    When SSL = FULL, I can view https://webmail.Domain.com.au and https://cpanel.Domain.com.au , however the issue is, is that when viewing the actual website (Domain.com.au), in some instances, it will show a different website from the server (when SSL = FULL)

    Is there anther setting or PAGE RULE that I can set, that will allow https://webmail.Domain.com.au and https://cpanel.Domain.com.au to work (ie. won’t display the ‘too many redirects’), while SSL = FLEXIBLE ?

    I have tried the PAGE RULE (Always USE HTTPS) with http://Domain.com.au/ , however that hasn’t resolved the issue.

    Any other ideas?

    Kind regards,

    Anthony

    P.S I have also put this on the Cloudflare forum as well, as wasn't sure where the best place to place it was:

    Viewing cpanel and webmail when running through Cloudflare
     
  2. cPanelMichael

    cPanelMichael Technical Support Community Manager Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    47,590
    Likes Received:
    2,186
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello Anthony,

    CloudFlare and service subdomains (e.g. cpanel.domain.tld, whm.domain.tld) are not fully compatible.

    You'll need to update the A records for the service subdomains (e.g. cpanel.domain.tld, whm.domain.tld) to the IP address of the cPanel server so that these subdomains are not proxied through CloudFlare. If you enable the AutoSSL feature, then signed certificates will be issued for these service subdomains.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. xman888

    xman888 Well-Known Member

    Joined:
    Nov 23, 2005
    Messages:
    61
    Likes Received:
    1
    Trophy Points:
    158
    Hello,

    Just an update on this.

    It was just one domain where the issue occurred when SSL in Cloudflare = FULL

    All other domains in Cloudflare are working well, when SSL = FULL, and I can access webmail.Domain.com.au and cpanel.domain.com.au without any issues (and under https).

    Kind regards,

    Anthony
     
  4. cPanelMichael

    cPanelMichael Technical Support Community Manager Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    47,590
    Likes Received:
    2,186
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello Anthony,

    Can you open a support ticket so we can take a closer look at the system? You can post the ticket number here and we'll link this thread to it.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice