The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Virtual Hosting, Main Shared IP, something messed up

Discussion in 'General Discussion' started by madmac, Jun 13, 2005.

  1. madmac

    madmac Well-Known Member

    Joined:
    Jan 11, 2004
    Messages:
    61
    Likes Received:
    0
    Trophy Points:
    6
    I have this weird situation.

    I created a shared account a few months back, and it seems to have taken over as the main server account.

    I have checked httpd.conf and all entries are correct and in the correct order, but it seems to be ignoring them.

    For example the main server IP should bring up the apache htdocs folder, which httpd.conf says it will, but this other account comes up instead.

    I cannot seem to create any new shared IP accounts either. If I do, this other account comes up.

    Also, if in WHM, I goto change an accounts IP address, the main server IP comes up as the main shared IP, but this is incorrect. I setup a different IP address as the main shared IP, and it had been working fine for a couple of years now, until I added this one account, and something seriously messed up.

    httpd.conf looks in order. Everything should be fine according to it, but several virtual host entries are being ignored.

    I'm going crazy because this effectively means I cannot make an IP account into a non-IP account (WHM lists the wrong IP in the drop down list, and then gives a error because it is taken, which it is). And I cannot make any new shared IP accounts. Well I can, but they do not work properly... this other site comes up at their address.

    I guess I should note that I have made the /etc/hosts file so cPanel cannot write to it... a few months before all of this started happening, cPanel started to mess up /etc/hosts every time it ran the auto-update each night, and I got tired of fixing that all the time, but thats another story.

    any clues?

    Thanks :)
     
    #1 madmac, Jun 13, 2005
    Last edited: Jun 13, 2005
  2. madmac

    madmac Well-Known Member

    Joined:
    Jan 11, 2004
    Messages:
    61
    Likes Received:
    0
    Trophy Points:
    6
    ok, I figured out the weird account thing... my account skeleton is just an index.html file that is symbolically linked, and apparently on this account, instead of replacing the index.html with their own file, they just decided to edit the file on the server, which edited the actual file and made it look like this other site was coming up on the main IP.

    However, I still have the very hair pulling problem of WHM not listing the correct main shared IP in the change IP form. The correct one is listed in the settings, and if I create a non-IP account, it creates it correctly and points it to the shared IP... just this one form will not pick it up.
     
Loading...

Share This Page