Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

virtualhost entries lost in httpd.conf after running rebuildhttpdconf

Discussion in 'EasyApache' started by iLinux85, Jan 21, 2017.

  1. iLinux85

    iLinux85 Active Member

    Joined:
    Mar 28, 2010
    Messages:
    39
    Likes Received:
    1
    Trophy Points:
    58
    I have problem , when i am trying to run /scripts/rebuildhttpdconf i got all my virtualhosts entries in httpd.conf gone

    I have like 3 websites in listaccount whm control panel page , after running this script i just only one website exist in httpd.conf with a wrong virtual ip address too

    I am trying to fix rebuildhttpdconf so i can be able to add ssl certificate to my website , but i can't because i got another error message when i am trying to add ssl

    The VirtualHost is invalid. It does not contain an IP address or port.

    I am running on

    Server version: Apache/2.2.29 (Unix)
    Server built: Oct 4 2014 00:34:13
    Cpanel::Easy::Apache v3.26.8 rev9999
    nginx version: nginx/1.6.2

    I don't want to update it to easyapache 4 unless it is necessary to fix this problem

    i am now locking /usr/local/apache/conf/httpd.conf file with chattr command so it wont update file automatically buy this command when cpanel trying to do maintenance update as regular
     
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    15,745
    Likes Received:
    312
    Trophy Points:
    433
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Are you manually editing this file?
     
Loading...

Share This Page