The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

VirtualHost uses WSGIScriptAlias and causing errors

Discussion in 'General Discussion' started by clinch, Apr 14, 2009.

  1. clinch

    clinch Member

    Joined:
    Mar 4, 2005
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    1
    I'm trying to use EasyApache3 to upgrade my Apache/PHP and I'm having a problem.

    One of my sites is built using Django and is currently using WSGI. I have set this one site up to use a custom VirtualHost template. This template includes the following line:

    Code:
     WSGIScriptAlias / "/home/username1/svn/djangoapp.wsgi"
    
    I know that this code works, because that's what I'm using currently, however when I try and rebuild Apache and PHP using EasyApache, I get the following error:

    Code:
     Syntax error on line 692 of /usr/local/apache/conf/httpd.conf.1239732284:
    Invalid command 'WSGIScriptAlias', perhaps misspelled or defined by a module not included in the server configuration
    
    I contacted support and they said:

    So I've gone and looked over the documentation, but I still don't see how I can get EasyApache to run without generating this error. How/where do I set up something that will allow me to use WSGIScriptAlias??
     
  2. clinch

    clinch Member

    Joined:
    Mar 4, 2005
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    1
    I'm still wondering how to do this, and I currently cannot rebuild apache because of the errors. Does anyone have any info that could help?
     
Loading...

Share This Page