The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Waiting for load to go down to continue

Discussion in 'General Discussion' started by micetrap, May 6, 2005.

Thread Status:
Not open for further replies.
  1. micetrap

    micetrap Member

    Joined:
    Sep 4, 2004
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    In WHM, I set it up to backup accounts to an FTP account on another server. Whenever it attempts to do the backup, it shuts down and says: "Waiting for load to go down to continue"


    root@freedom [~]# /scripts/cpbackup
    [3] 20136
    root@freedom [~]# Daily Backup is up to date
    Waiting for load to go down to continue
    pkgacct started.
    pkgacct version 3.1 - running with uid 0
    using time::hires for speedups
    Copying Reseller Config...Done
    Copying SSL Certificates, CSRS, and Keys...Done
    Copying Mail files....Done
    Copying frontpage files....Done
    Copying proftpd file....Done
    Entering timeout safety mode
    Grabbing mysql dbs............
    Done
    Grabbing mysql privs...Done
    Leaving timeout safety mode
    Copying mailman lists....Done
    Copying mailman archives....Done
    Copying homedir....Waiting for load to go down to continue

    This is the only time I have seen any overloads, it only happens during the backup. So far, I have not been able to get anything more than 1 account transferred, then it shuts down. Can someone help me with this?
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Try searching the forums for Waiting for load to go down to continue
     
  3. micetrap

    micetrap Member

    Joined:
    Sep 4, 2004
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    I am still getting the "Waiting for load to go down to continue" error when trying to run backups. In WHM, I have the load set to 10 where it would red line it. Is there another place I need to edit it to change the load allowance? The problem is that it ends up timing out the FTP, so the backups are never finishing.

    I get this error when attempting backups manually: Timeout at /usr/lib/perl5/5.8.0/Net/FTP.pm line 789
     
  4. Nickey

    Nickey Member

    Joined:
    Apr 14, 2005
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    Waiting for load go down

    Cpanel "thinks" that your load cannot get higher then your system processors count :)
    So, increasing CPU count in WHM/tweak (or somewhere there) is the key to your problem. Also this setting can be changed in /var/cpanel/cpanel.config, variable is named something with "cpu".

    Setting this to 10 makes garantie that your backups will continue with system load up to 10 (and so on).

    Enjoy
     
  5. tugacari

    tugacari Registered

    Joined:
    Apr 20, 2008
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Tweak Settings >> loadthreshold

    Hey,
    Go to "Main >> Server Configuration >> Tweak Settings" in cpanel and change
    setting "loadthreshold" to the load you want, this will make the cpanel backup to run under the load limit you've just set.
    I hope it helps.
     
  6. cPanelJared

    cPanelJared Technical Analyst
    Staff Member

    Joined:
    Feb 25, 2010
    Messages:
    1,842
    Likes Received:
    18
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    Main >> Server Configuration >> Tweak Settings

    This value is now labeled The load average above the number of cpus at which logs file processing should be suspended in Main >> Server Configuration >> Tweak Settings. It corresponds to the value extracpus= in /var/cpanel/cpanel.config.

    I am now closing this thread to avoid future confusion.
     
Loading...
Thread Status:
Not open for further replies.

Share This Page