The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Waiting for Port 2084 to be free

Discussion in 'General Discussion' started by Tom Pyles, Mar 21, 2003.

  1. Tom Pyles

    Tom Pyles Well-Known Member

    Joined:
    Apr 26, 2002
    Messages:
    254
    Likes Received:
    0
    Trophy Points:
    16
    Was just updating to the latest edge version and looks like everything was going fine until the very end. The servers are all throwing back a 'Waiting for port 2084 to be free' It just keeps repeating this message :(
     
  2. FWC

    FWC Well-Known Member

    Joined:
    May 13, 2002
    Messages:
    354
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Ontario, Canada
    Try:

    netstat -anp | grep 2084

    That will show you the PID # binding to that port.

    Then you can try a kill -9 on that PID #.
     
  3. UberSkilled

    UberSkilled Member

    Joined:
    Feb 26, 2006
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Same problem - 3 years later

    I've got the same problem - I did a netstat (FreeBSD 5.x)...

    [root@buck:~] netstat -an | grep 2084
    tcp4 0 0 *.2084 *.* LISTEN


    I don't see a process number =/. And I can't see what's running it.



    the "can't listen on 2084" error message happens when I try to (re)start cPanel. I can access WHM fine, and cPanel was giving me a blank page when I tried to log in...


    Now I can't run cPanel at all >.<.



    Thanks guys,




    /Whitey - UberSkilled.com Admin
     
  4. UberSkilled

    UberSkilled Member

    Joined:
    Feb 26, 2006
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Still waiting for a reply, thanks guys :).




    /Whitey
     
  5. Murtaza_t

    Murtaza_t Well-Known Member

    Joined:
    Jan 24, 2005
    Messages:
    476
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Earth
    cPanel Access Level:
    Website Owner
    I think a reboot would fix this problem.
     
  6. evn7289

    evn7289 Registered

    Joined:
    Apr 24, 2006
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    I just updated to the latest "edge" as well. I know have that error. It is keeping my server from booting up. HELP!

    Erik
     
  7. dote

    dote Member

    Joined:
    Dec 28, 2005
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Disable CPanel's entrophychat

    We had this problem as well. Performing a netstat -anp indicated that entropychat was binding to port 2084. Looking at /etc/init.d/cpanel, you can disable this feature by creating a file called /etc/entropychatdisable

    # touch /etc/entropychatdisable

    Then restart cpanel. Worked for us.
     
  8. Cwebz

    Cwebz Member

    Joined:
    Jan 19, 2006
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Minnesota
    cPanel Access Level:
    Root Administrator
    I keep having that problem I tryed the method you said works great .. I hope it stays this time .. the last time I had my webhosting do something..
     
  9. drjohn5452

    drjohn5452 Registered

    Joined:
    Jun 1, 2008
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Relocated server

    I am getting the waiting for port 2084 to free.
    When I do the netstat - anp situation it comes back with:

    Active internet connections (w/o servers)
    Proto recv-Q send-Q Local address Foreign address state

    Then a stream of unix 2 and 3 data sone connected etc

    This is new to me so any ideas folks???
     
Loading...

Share This Page