The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

want to restore an account, files will not populate Mysql tables

Discussion in 'General Discussion' started by sleuth1, Sep 24, 2003.

  1. sleuth1

    sleuth1 Well-Known Member

    Joined:
    Mar 16, 2003
    Messages:
    75
    Likes Received:
    0
    Trophy Points:
    6
    I have a full back as a tar file sitting on my server , I have tried to restore the full site including the DBs , the info is there it just will not populate or create the tables. it is an xmb1 DB, already created in cpanel Can any one help with this, the account user deleted there forum DB and I have tried repeatedlty to restore. there is no sql file as such just the unzipped files containing all the info that should populate the xmb1 DB but it refuses to do this, no errors just no tables, any advice,. thanks.

    Being trying to restore as a cpanel full backup restore from my own computer, no joy.

    cPanel.net Support Ticket Number:
     
  2. mickeymouse

    mickeymouse Well-Known Member

    Joined:
    Sep 16, 2003
    Messages:
    389
    Likes Received:
    0
    Trophy Points:
    16
    Dear sleuth1,

    You can use the mysqlimport tool for creating database(with files). Login in to mysql prompt, use mysqlimport for specifying the source of the file. If you do not have the database structure in those files, there is no way for you to create a database from just the data. You have to manually look in to the data and create the database yourself.

    Regards,
     
  3. neptho

    neptho Registered

    Joined:
    Aug 2, 2006
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Ok, I know it's a faux-paus bumping a three year dead thread, but:

    I'm having exactly the same problem. Within the tarball is mysql.sql and mysql/*.sql, which are for the tables created/etc for this user.

    It restores/cpmove from this fine, and even creates the database, but it doesn't populate the tables. Nothing. DB has got zed, zero, zilch, nada, null.

    Being that I had to import each subaccount manually, I'm quite annoyed to find that this format doesn't have the db name encoded - so I can't just pipe it to mysql.

    I've looked and I'm not out of space, anywhere, and don't see any strange mysql or console messages when importing.

    Any ideas?
     
  4. brianoz

    brianoz Well-Known Member

    Joined:
    Mar 13, 2004
    Messages:
    1,146
    Likes Received:
    6
    Trophy Points:
    38
    Location:
    Melbourne, Australia
    cPanel Access Level:
    Root Administrator
    I'd re-run the import by hand and look for a failure message, that is the most effective way to find out what's going on.

    Just guessing here - it's possible that the dump needed "-Q" to mysqldump and that wasn't used - in other words, some of the table names were reserved words. Just a guess - if this is the case you may be able to solve the problem by appropriately quoting table and/or column names.
     
Loading...

Share This Page