The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

want whm to automatically https

Discussion in 'General Discussion' started by ladydi711, Jun 1, 2005.

  1. ladydi711

    ladydi711 Well-Known Member

    Joined:
    Sep 4, 2001
    Messages:
    120
    Likes Received:
    3
    Trophy Points:
    18
    i got a replacement server; my old server was 9.9.2 and in Tweak Settings, I had the options to "When users access /cpanel or /whm or /webmail on their domain redirect them to the https(ssl) port instead of the insecure one"

    My new server is 10.2.0 and I don't see that available, so my /whm /cpanel /webmail are all using http.

    Where is the setting in the newer version?

    Thanks in advance,
    Diane
     
  2. flash7

    flash7 Well-Known Member

    Joined:
    Feb 16, 2004
    Messages:
    203
    Likes Received:
    0
    Trophy Points:
    16
    Hello,
    add in your httpd.conf
    Code:
    ScriptAlias /securewhm /usr/local/cpanel/cgi-sys/swhmredirect.cgi
    ScriptAlias /cpanel /usr/local/cpanel/cgi-sys/redirect.cgi
    ScriptAlias /webmail /usr/local/cpanel/cgi-sys/wredirect.cgi
     
  3. ladydi711

    ladydi711 Well-Known Member

    Joined:
    Sep 4, 2001
    Messages:
    120
    Likes Received:
    3
    Trophy Points:
    18
    Those are actually already in there.

    securewhm does indeed work; I can use that rather than whm
    But cpanel and webmail do not go to the https they just go to the regular http on port 8082.

    Is there something else?

    Thanks!
     
  4. sawbuck

    sawbuck Well-Known Member

    Joined:
    Jan 18, 2004
    Messages:
    1,367
    Likes Received:
    5
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    This line in Tweak Settings - Always redirect users to the ssl/tls ports when visiting /cpanel, /webmail, etc. still exists in 10.2.0-R82.
     
  5. ladydi711

    ladydi711 Well-Known Member

    Joined:
    Sep 4, 2001
    Messages:
    120
    Likes Received:
    3
    Trophy Points:
    18
    Thanks! I overlooked that setting... that's it!
     
Loading...

Share This Page