Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

WARN You must use an IP address that is on the server

Discussion in 'Security' started by dhaval1983, Jan 2, 2018.

Tags:
  1. dhaval1983

    dhaval1983 Registered

    Joined:
    Jan 2, 2018
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Ahmedabad
    cPanel Access Level:
    Website Owner
    Hi,
    I get following error while installing an SSL with Cpanel Auto-SSL with Let’s encrypt - can yo please help.

    Code:
    WARN You must use an IP address that is on the server. “server IP address” is not bound. at /usr/local/cpanel/Cpanel/SSL/Auto/Provider.pm line 800.
    
    WARN (XID h7czh4) The system failed to install an SSL certificate onto the website “example.com” because of the following error: You must use an IP address that is on the server. “server ip address” is not bound.
    
    I get this error while installation of auto SSL using let’s encrypt
     
    #1 dhaval1983, Jan 2, 2018
    Last edited by a moderator: Jan 2, 2018
  2. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    45,167
    Likes Received:
    1,933
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello,

    Could you browse to "WHM Home » Server Configuration » Basic WebHost Manager® Setup" in WHM, and verify what's configured for the option labeled "The ethernet device onto which new IP addresses are added. Devices detected with at least one IP are listed in the drop-down, or you may specify another device."? Are you using a loopback address for this option instead of the Ethernet device associated with the IP address?

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. adavea

    adavea Registered

    Joined:
    Sep 23, 2018
    Messages:
    1
    Likes Received:
    1
    Trophy Points:
    1
    Location:
    New York
    cPanel Access Level:
    Root Administrator
    I ran into this problem as well when re-upping my ssl for - Removed -. If you have multiple domains, you need to create one cert per domain, and install them separately. Also, with letsencrypt and godaddy, for some reason you don't need to specifically specify www.example.com and example.com, just create a cert for example.com and install it to that domain.

    So for instance if you have SUB.example.COM and example.COM in the domain dropdown of the SSL/TLS "Install an SSL website" domain dropdown, then create 1 cert for SUB.example.COM with certbot, install it, then redo that entire process for example.COM.
     
    #4 adavea, Sep 23, 2018
    Last edited by a moderator: Sep 23, 2018
    cPanelMichael likes this.
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice