Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Warning: cPanel is unable to verify that this server is an authoritative nameserver

Discussion in 'E-mail Discussion' started by Reiyad, Mar 7, 2018.

  1. Reiyad

    Reiyad Member

    Joined:
    Jan 20, 2017
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Jordan
    cPanel Access Level:
    Root Administrator
    Hello,

    It seems like I can not get my SPF enabled at all, the problem is I had the wrong MX record setup when I created a cpanel account, however I was still being able to send and receive emails, however emails were getting sent to spam folder in email.

    I also remember I had the SPF enabled in Cpanel, what exactly happened is that I went and fixed my mx records just now but on the cpanel I keep getting this message:
    Warning: cPanel is unable to verify that this server is an authoritative nameserver for domainname.com

    So can this be auto corrected from the WHM, or do I have to do something? Like reset the dns zones or something, no idea.

    Please help, thanks in advance.

    Rei
     
  2. Reiyad

    Reiyad Member

    Joined:
    Jan 20, 2017
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Jordan
    cPanel Access Level:
    Root Administrator
    Problem solved, you can close this thread, I had to add the txt record.

    Thanks
     
  3. Reiyad

    Reiyad Member

    Joined:
    Jan 20, 2017
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Jordan
    cPanel Access Level:
    Root Administrator
    Yea but still emails are getting received to the spam folder, how can I fix this?

    Thanks
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    43,961
    Likes Received:
    1,821
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    This message appears when the cPanel server detects that your domain name uses remote name servers. Check to verify your domain name uses name servers with IP addresses associated with your cPanel server (or it's DNS cluster). If that's the case, then you will need to switch name servers or manually add the TXT records for the domain name at it's DNS hosting provider.

    The first step is to ensure your server is following the guidelines we document at:

    How to Keep your Email Out of the Spam Folder - cPanel Knowledge Base - cPanel Documentation

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. Reiyad

    Reiyad Member

    Joined:
    Jan 20, 2017
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Jordan
    cPanel Access Level:
    Root Administrator
    Hello,

    Thank you for the prompt reply, to be honest this document is not clear. I read it before and I couldn't get the idea.

    All my problems are solved now but I still have one problem, which is the DKIM, the strange thing is that sometimes DKIM says Status: Enabled Active (DNS Check Passed) and some other times it says Warning: cPanel is unable to verify that this server is an authoritative nameserver for "domainname"

    I am not sure if this is a bug in cpanel, every time I refresh the Authentication page in cPanel I get different results one time DNS Chceck Passed and the other time unable to verify nameserver.

    I don't use any cluster, my name servers are
    ns1.example.com
    ns2.example.com

    Again I got the SPF working by adding a TXT record: v=spf1 a mx ptr ?all

    I also added another TXT record for DKIM using the public key that I have in the DKIM authorization console in cpanel.

    When I go to WHM edit dns zone the public key of is same as cpanel, I actually tried to change it as I read that you have to remove the quotation marks and join the string together, since the key has space in it in cpanel.

    Also I read another post where it says use the following commands

    Code:
    cd  /var/cpanel/domain_keys/public/
    
    more yourdomainame.com
    Then I copied the key I got as a txt record with default_domainkey selector, still not getting it to work

    So I am really not sure what else I shall do?

    I look forward to hearing your thoughts

    Many thanks,
    Rei
     
    #5 Reiyad, Mar 7, 2018
    Last edited by a moderator: Mar 7, 2018
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    43,961
    Likes Received:
    1,821
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    You shouldn't need to manually add the TXT record for DKIM. You can remove the existing TXT record from the zone, and then enable DKIM via the Authentication feature in cPanel.

    Feel free to open a support ticket using the link in my signature and we can take a closer look to see why this is happening.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice