The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Warning: Failed opening '/usr/local/cpanel/base/horde/config/horde.php'

Discussion in 'General Discussion' started by XPerties, Nov 19, 2003.

  1. XPerties

    XPerties Well-Known Member

    Joined:
    Apr 10, 2003
    Messages:
    401
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    New Jersey, USA
    Warning: Failed opening '/usr/local/cpanel/base/horde/config/horde.php' for inclusion (include_path='/usr/local/cpanel/3rdparty/lib/php/:.') in /usr/local/cpanel/base/horde/lib/Registry.php on line 588

    Anyone else get this when clicking on horde link in cpanel?


    WHM 8.5.4 cPanel 8.5.4-R7
     
  2. bear

    bear Well-Known Member

    Joined:
    Sep 24, 2002
    Messages:
    113
    Likes Received:
    1
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    I beleive this is a permissions problem. It is owned by root, but should be owned by cpanel. Log in to root and chown the file or the entire folder.
     
  3. TCSLEA

    TCSLEA Active Member

    Joined:
    Oct 29, 2003
    Messages:
    36
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Austin, T E X A S
    I just happen to select Horde to try it out this morning, and received the same error message. Only the horde.php file was owned by root. The suggested fix of changing it to be owned by cpanel did the trick.

    Thanks for that suggestion!
     
  4. XPerties

    XPerties Well-Known Member

    Joined:
    Apr 10, 2003
    Messages:
    401
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    New Jersey, USA
    I know the command to chmod files but how do you chmod entire directory?
     
  5. bear

    bear Well-Known Member

    Joined:
    Sep 24, 2002
    Messages:
    113
    Likes Received:
    1
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    chown -R user.user path/foldername
     
  6. XPerties

    XPerties Well-Known Member

    Joined:
    Apr 10, 2003
    Messages:
    401
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    New Jersey, USA
    nevermind, Seems it was just horde.php also. Suggestion for fix worked. Thank you.
     
  7. TCSLEA

    TCSLEA Active Member

    Joined:
    Oct 29, 2003
    Messages:
    36
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Austin, T E X A S
    Even better solution (as suggested elsewhere in these forums)

    After my initial reply about changing only horde.php, I soon discovered numerous other errors when trying to use Horde. I eventually chown the entire horde directory to solve all Horde problems:


    Code:
    chown -R cpanel:cpanel /usr/local/cpanel/base/horde
    Note the syntax of owner:group - I'm using FreeBSD and that's correct for that OS. I've seen others use a period (owner.group) which may be correct for other OS - I don't know.
     
  8. bear

    bear Well-Known Member

    Joined:
    Sep 24, 2002
    Messages:
    113
    Likes Received:
    1
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    It was suggested in the second post of this thread as well.
     
  9. pugleon

    pugleon Guest

    My knowledge of linux commands is limited as I am new to it. And did need an option to change permissions on a folder that was locked and working change with cpanel (even though all my cpanel settings and versions are as they should be). And that worked perfectly. Begining to dig freebsd, reminds me of dos in the hay day :p
     
Loading...

Share This Page