The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Warning: fsockopen(): unable to connect to localhost:25

Discussion in 'General Discussion' started by mahdionline, Jul 20, 2006.

  1. mahdionline

    mahdionline Well-Known Member

    Joined:
    Oct 18, 2003
    Messages:
    127
    Likes Received:
    0
    Trophy Points:
    16
    Hi,

    after a reboot (by EV1 panel), I get this error in one of our php script :


    Warning: fsockopen(): unable to connect to localhost:25 in . . ..


    What's the problem ?

    regard
     
  2. webignition

    webignition Well-Known Member

    Joined:
    Jan 22, 2005
    Messages:
    1,880
    Likes Received:
    0
    Trophy Points:
    36
    Does the same happen with the IP or domain name?
     
  3. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Make sure you haven't enabled the WHM > Tweak Security > SMTP Tweak, as that's exactly what that does.
     
  4. mahdionline

    mahdionline Well-Known Member

    Joined:
    Oct 18, 2003
    Messages:
    127
    Likes Received:
    0
    Trophy Points:
    16
    No, We use port 25.

    All thing was done before Reboot.

    :mad:
     
  5. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    You seem to be consuing what I said with something else. Have you checked that that setting I mentioned is not enabled? That setting blocks access to port 25 from localhost.
     
  6. biggdogg285

    biggdogg285 Well-Known Member

    Joined:
    May 14, 2004
    Messages:
    71
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Root Administrator
    I'm just wondering if you think this SMTP tweak should be on or off.
    Do you have it enabled or disabled?
     
  7. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    I don't use it myself. However, if you believe you have outgoing spam abusing port 25, then it's worth implementing unless you use an iptables configuration script. In that case, you would have to use that to block port 25 in ther same manner as the SMTP Tweak does.
     
  8. biggdogg285

    biggdogg285 Well-Known Member

    Joined:
    May 14, 2004
    Messages:
    71
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Root Administrator
    I understand. Thank you for your reply...

    Regards
     
Loading...

Share This Page