Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SOLVED Warning in phpMyAddmin

Discussion in 'Database Discussions' started by fullfatdesigns, Dec 4, 2017.

Tags:
  1. fullfatdesigns

    fullfatdesigns Active Member

    Joined:
    Aug 1, 2014
    Messages:
    37
    Likes Received:
    5
    Trophy Points:
    8
    cPanel Access Level:
    Root Administrator
    Hi

    I'm getting the following error in phpMyAdmin, but for only one of my databases;

    Code:
    Warning in ./libraries/plugins/auth/AuthenticationCpanel.php#627
     mysqli_connect(): (28000/1045): Access denied for user 'usenamehere'@'localhost' (using password: YES)
    
    Backtrace
    
    ./libraries/plugins/auth/AuthenticationCpanel.php#627: mysqli_connect(
    string ********,
    string ********,
    string ********,
    string ********,
    string ********,
    )
    ./libraries/plugins/auth/AuthenticationCpanel.php#387: PMA\libraries\plugins\auth\AuthenticationCpanel::cp_mysql_auth_check(
    string 'username',
    string 'password',
    )
    ./libraries/common.inc.php#667: PMA\libraries\plugins\auth\AuthenticationCpanel->authCheck()
    ./index.php#20: require_once(./libraries/common.inc.php)
    and

    Code:
    Deprecation Notice in ./libraries/plugins/auth/AuthenticationCpanel.php#644
     Function split() is deprecated
    
    Backtrace
    
    ./libraries/plugins/auth/AuthenticationCpanel.php#644: split()
    ./libraries/plugins/auth/AuthenticationCpanel.php#398: PMA\libraries\plugins\auth\AuthenticationCpanel::cp_get_my_cnf_vars(string '/home/lacepartners/.my.cnf')
    ./libraries/common.inc.php#667: PMA\libraries\plugins\auth\AuthenticationCpanel->authCheck()
    ./index.php#20: require_once(./libraries/common.inc.php)
    I've only noticed this today and its been a few months since I last did any work on it.

    Any advice would be welcome.

    EDIT: Forgot to add... the site seems to work and display OK.

    Wayne
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    41,516
    Likes Received:
    1,616
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Can you try resetting the password for the cPanel account associated with that database via "WHM >> Password Modification" to see if the issue persists?

    Thank you.
     
  3. fullfatdesigns

    fullfatdesigns Active Member

    Joined:
    Aug 1, 2014
    Messages:
    37
    Likes Received:
    5
    Trophy Points:
    8
    cPanel Access Level:
    Root Administrator
    Hi

    Same issue after resetting the password for that account. Should I trying checking the synchronise mySQL password too?
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    41,516
    Likes Received:
    1,616
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Yes, please select that option and try again.

    Thank you.
     
  5. fullfatdesigns

    fullfatdesigns Active Member

    Joined:
    Aug 1, 2014
    Messages:
    37
    Likes Received:
    5
    Trophy Points:
    8
    cPanel Access Level:
    Root Administrator
    This has solved it, thank you.
     
    cPanelMichael likes this.
Loading...

Share This Page