Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Warning Interchange failed!

Discussion in 'General Discussion' started by nwood, Feb 13, 2005.

  1. nwood

    nwood Registered

    Joined:
    Feb 13, 2005
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    151
    Hello, every two min I get an email that is from WHM that said Interchange failed! Is there anyway to turn Interchange off as I do not use it at all! I am a server admin :confused:
     
  2. dalem

    dalem Well-Known Member
    PartnerNOC

    Joined:
    Oct 24, 2003
    Messages:
    2,610
    Likes Received:
    51
    Trophy Points:
    203
    Location:
    SLC
    cPanel Access Level:
    DataCenter Provider
    1. tweek settings
    software
    interchange disable

    2. Service Configuration
    Service Manager
    uncheck interchange
     
  3. nwood

    nwood Registered

    Joined:
    Feb 13, 2005
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    151
    Okay Thanks! :)
     
  4. taotoon

    taotoon Well-Known Member

    Joined:
    Nov 14, 2004
    Messages:
    135
    Likes Received:
    0
    Trophy Points:
    166
    I did those 2 steps correctly and no email warning message.
    but cpanel client accesss show in "server status" as "failed".

    Can we remove the red LED status in cpanel client ?
     
  5. AndyReed

    AndyReed Well-Known Member
    PartnerNOC

    Joined:
    May 29, 2004
    Messages:
    2,222
    Likes Received:
    3
    Trophy Points:
    193
    Location:
    Minneapolis, MN
    First, SSH to your server, then:
    1- Remove /etc/chkserv.d/interchange and /var/run/chkservd files
    2- Restart the cpsrvd daemon
    3- Restart CPanel

    If none of these work for you, reboot your server.
     
  6. snardi67

    snardi67 Member

    Joined:
    Jun 4, 2005
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    151
    Why is it that interchange fails constantly? I've had to go thru these steps several times in the past and find that interchange although embedded and included with cpanel doesn't ever seem to actually work.
     
  7. taotoon

    taotoon Well-Known Member

    Joined:
    Nov 14, 2004
    Messages:
    135
    Likes Received:
    0
    Trophy Points:
    166
    My WHM/Cpanel was 10.2.0-S83, I upgraded to 10.2.0-R82 still face the same problem.

    I disabled many services.

    - spamd ( spam assasin )
    - imapd
    - interchange

    I tried to restart Cpanel and Chkservd.

    /etc/init.d/chkservd restart
    /etc/init.d/cpanel restart

    But those services still list on cpanel client.
    Finally, I tried to reboot and it works!

    I read many topics here and still don't know why reboot can solve it.
    And what are wrong with chkservd ?
    Why chkservd don't know that we disable some services unless we reboot the server.


    Hope these are usefuls for many newbies.
     
Loading...

Share This Page