The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Warning: mysql_connect(): Client does not support authentication protocol requested

Discussion in 'General Discussion' started by craigbrass, Mar 24, 2005.

  1. craigbrass

    craigbrass Active Member

    Joined:
    Nov 17, 2003
    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    1
    "Warning: mysql_connect(): Client does not support authentication protocol requested by server; consider upgrading MySQL client in /home/subsonic/public_html/index.php on line 15"

    Thats what I get for all scripts on a particular account. Any way to fix this?
     
  2. AndyReed

    AndyReed Well-Known Member
    PartnerNOC

    Joined:
    May 29, 2004
    Messages:
    2,222
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Minneapolis, MN
    What Php verion do you have on your server?
     
  3. Blue|Fusion

    Blue|Fusion Well-Known Member

    Joined:
    Sep 12, 2004
    Messages:
    378
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Cleveland, Ohio
    I had this problem a few weeks back when I upgraded from MySQL 4.1.10 to 4.1.10a.

    Add the following under [mysqld] in /etc/my.cnf:
    old-passwords

    You'll have to edit the passwords of some of the already created databases. You can see which ones need in it mysql database in root phpMyAdmin.
     
Loading...

Share This Page