The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Warning - Reverse DNS does not match SMTP Banner

Discussion in 'Bind / DNS / Nameserver Issues' started by marypearson, Jul 3, 2014.

  1. marypearson

    marypearson Member

    Joined:
    Feb 16, 2014
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    I'm wondering if anyone can help with the notice I'm getting from MXToolbox:

    "Warning - Reverse DNS does not match SMTP Banner" I am getting it for both christiangays.com and server.mapenterprises.ca

    I have rDNS set up:

    rDNS: IP: 204.44.87.89
 Domain: christiangays.com
    rDNS: IP: 204.44.86.144 
Domain: server.mapenterprises.ca

    I think I need a PTR record but don't know what I'm supposed to enter in the boxes to add one. I really don't know what the SMTP Banner is that they are referring to. Any ideas how I can fix this issue?

    Many thanks!
     
  2. vanessa

    vanessa Well-Known Member
    PartnerNOC

    Joined:
    Sep 26, 2006
    Messages:
    817
    Likes Received:
    22
    Trophy Points:
    18
    Location:
    Virginia Beach, VA
    cPanel Access Level:
    DataCenter Provider
    Hi Mary,

    Based on limited testing, your SMTP banner is showing server.mapenterprises.ca

    Code:
    EHLO v-nessa.net
    250-server.mapenterprises.ca Hello v-nessa.net [173.247.247.102]
    
    You should see which IP your email is being sent from, and set it to the above hostname. You can most easily test this by sending an email from the server to yourself to see what IP shows up as the sender, either 204.44.87.89 or 204.44.86.144.

    Alternatively, you can enable the setting in the Exim configuration editor in WHM to send email from a domain's dedicated IP, which may also resolve this so that email from christiangays.com is sent from 204.44.87.89.
     
  3. marypearson

    marypearson Member

    Joined:
    Feb 16, 2014
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    OMG you have been so helpful! Thank you. I did as you said. I sent myself an email and it is being sent through 204.44.87.89 which is the christiangays.com IP, not the server.mapenterprises.ca IP.

    domain of christiangays.com designates 204.44.87.89 as permitted sender
    I have two IP's, both of which are shared with several websites (who use my mail server) on each IP. What do you advise? Should I perhaps get another dedicated IP strictly for sending mail?

    Thank you!!!!!
     
  4. vanessa

    vanessa Well-Known Member
    PartnerNOC

    Joined:
    Sep 26, 2006
    Messages:
    817
    Likes Received:
    22
    Trophy Points:
    18
    Location:
    Virginia Beach, VA
    cPanel Access Level:
    DataCenter Provider
    You should then just send email from the main server IP that resolves to server.mapenterprises.ca. It's possible that to do this you'll need to uncheck the option in WHM Exim config editor that is dictating that email be sent from a site's dedicated IP:

    Domains and IPs

    You can alternatively get a third IP for email, but that's probably unnecessary.
     
  5. marypearson

    marypearson Member

    Joined:
    Feb 16, 2014
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    Thank you again. I have changed the Exim Config Manager/Domains and IPs to "Send mail from account's dedicated IP address" - but it doesn't say what IP it is using and it didn't show up in the header of my test letter. It just showed server.mapenterprises.ca so I am assuming 204.44.86.144


    When they use the term "dedicated" do they just mean the domain's IP? so do my sites on 204.44.87.89 send from it or do they send from 204.44.86.144
 ?

    I still have the MXToolbox showing SMTP Reverse DNS Mismatch Warning - Reverse DNS does not match SMTP Banner for both christiangays.com and server.mapenterprises.ca Is this just a matter of waiting till it propagates or how can I resolve the problem?

    Thank you!
     
  6. vanessa

    vanessa Well-Known Member
    PartnerNOC

    Joined:
    Sep 26, 2006
    Messages:
    817
    Likes Received:
    22
    Trophy Points:
    18
    Location:
    Virginia Beach, VA
    cPanel Access Level:
    DataCenter Provider
    The dedicated IP is an IP assigned to a cPanel account. When the box is unchecked the server should send email from the main IP (204.44.86.144
), so this is why I suggested unchecking it.

    Also, just now you mention you are using MXtoolbox to check this. I really wouldn't take that to heart, because it cannot tell what IP your server is SENDING email from, only what server it responds to when it connects to port 25. So if your server is sending from an IP address with a PTR that matches the EHLO/HELO name shown in the header of the email, you're fine.
     
  7. marypearson

    marypearson Member

    Joined:
    Feb 16, 2014
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    My mistake. I thought I was supposed to check "on" for "Send mail from account’s dedicated IP address". I have set it back to off.

    << So if your server is sending from an IP address with a PTR that matches the EHLO/HELO name shown in the header of the email, you're fine. >>

    Can you tell me how I check this please.
     
Loading...

Share This Page