The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Warning: setlocale() [function.setlocale

Discussion in 'General Discussion' started by Silverado, Mar 20, 2003.

  1. Silverado

    Silverado Well-Known Member

    Joined:
    Mar 19, 2003
    Messages:
    154
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Backyard - Poolside
    Warning: setlocale() [function.setlocale]: Passing locale category name as string is deprecated. Use the LC_* -constants instead. in /home/*****/public_html/modules/Web_Links/index.php on line 772



    This is the error a client of mine is receiving on PHP Nuke after we upgraded to 6.0. Can anyone shed some light on this for me please? I really don't use PHP Nuke and am just hoping for a quick fix here.
     
  2. Noldar

    Noldar Well-Known Member

    Joined:
    Jun 26, 2002
    Messages:
    64
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Ponchatoula, LA
  3. Silverado

    Silverado Well-Known Member

    Joined:
    Mar 19, 2003
    Messages:
    154
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Backyard - Poolside
    Hey Thanks.. I will try that first thing in the Morning. And I thought I searched everywhere. :rolleyes:
     
  4. prudhvik

    prudhvik Member

    Joined:
    Oct 16, 2002
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Hey,

    It seems you upgraded server to php 4.3.1 which gives this error.
    you need to change your scripts as per 4.3.1 then it should be fine.
     
  5. PPNSteve

    PPNSteve Well-Known Member

    Joined:
    Mar 13, 2003
    Messages:
    393
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Somewhere in Ilex Forest
    cPanel Access Level:
    Root Administrator
    Twitter:
    it's easy to fix in Nuke - you just edit one line in mainfile.php and it's like on line 569

    nuke ver 6.5 fixes this issue.. just a quick heads up..
     
  6. L4S

    L4S Well-Known Member

    Joined:
    Feb 23, 2003
    Messages:
    47
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Australia
    I found the following fix:


    @setlocale (LC_TIME, $locale);

    all worked OK after @ symbol was inseted in fromt of the code.
     
Loading...

Share This Page