was encoded with the PHP 5.3 ionCube Encoder and requires PHP 5.3 to be installed

aarango

Member
PartnerNOC
Dec 4, 2013
7
0
1
cPanel Access Level
Root Administrator
Hello,

I have a issue installing a plugin for WHMCS. When I installed a plugin I get this error:
"was encoded with the PHP 5.3 ionCube Encoder and requires PHP 5.3 to be installed"

In server I have version php 5.3.28 and this information with this command:

# php -v
PHP 5.2.17 (cli) (built: Mar 18 2012 00:16:20)
Copyright (c) 1997-2010 The PHP Group
Zend Engine v2.2.0, Copyright (c) 1998-2010 Zend Technologies
with the ionCube PHP Loader v4.4.1, Copyright (c) 2002-2013, by ionCube Ltd., and
with Zend Optimizer v3.3.9, Copyright (c) 1998-2009, by Zend Technologies

What should I update? php ioncube loader? I tried to do it with easyapache but last version 5.3.28 (centos 4.5) and I can't update it more, any ideas please?

Thanks a lot.
 

cPanelMichael

Technical Support Community Manager
Staff member
Apr 11, 2011
47,911
2,233
363
cPanel Access Level
DataCenter Provider
Twitter
Hello :)

You mentioned that you have installed PHP version 5.3, yet the "php -v" output shows PHP version 5.2. Are you sure you have selected PHP 5.3 in EasyApache and rebuilt Apache/PHP?

Thank you.