The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

was you able to upgrade your server to php 5.1.4 using easypache ?

Discussion in 'General Discussion' started by Radio_Head, May 24, 2006.

?

was you able to upgrade to php5.1.4 with easypache without any other tweak ?

  1. YES

    25 vote(s)
    26.6%
  2. NO

    69 vote(s)
    73.4%
  1. Radio_Head

    Radio_Head Well-Known Member

    Joined:
    Feb 15, 2002
    Messages:
    2,051
    Likes Received:
    1
    Trophy Points:
    38
    were you able to upgrade your server to php 5.1.4 using easypache ?

    were you able to upgrade your server to php 5.1.4 using easypache (without any other tweak) ?


    For me is impossible to update to 5.1.4 using easyapache . Or php file are downloaded , or it shows a blank page , or I have mutiple copies of php and only 4.4.2 works , or other problems ... nothing to do from weeks ,it's impossible to install 5.1.4 using easypache on all my servers. Was you able ONLY using easyapche ?
     
    #1 Radio_Head, May 24, 2006
    Last edited: May 30, 2006
  2. Olate

    Olate Active Member

    Joined:
    Aug 1, 2003
    Messages:
    42
    Likes Received:
    0
    Trophy Points:
    6
  3. Radio_Head

    Radio_Head Well-Known Member

    Joined:
    Feb 15, 2002
    Messages:
    2,051
    Likes Received:
    1
    Trophy Points:
    38
    70% doesn't work ... Darkorb ? Is it enough to review easypache ?
     
  4. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    There are known bugs with mysql that prevent this from working on Linux. (Freebsd is fine).

    Please use the search feature.
     
  5. OmaniMan

    OmaniMan Member

    Joined:
    Feb 12, 2004
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    No I Couldn't ..
    I had :
    CentOs 4.3

    Before I used easyapache ...

    My Server features :
    1) PHP 5.1.4
    2) Apache 1.3.3.4

    After I use easyapache :
    1) The apache isn't working !
    2) The php has been downgrade to 4.4.2 !

    Can any one help me to upgrade PHP again please ?
     
  6. Radio_Head

    Radio_Head Well-Known Member

    Joined:
    Feb 15, 2002
    Messages:
    2,051
    Likes Received:
    1
    Trophy Points:
    38
    interesting ... could be fine to have this thread "sticky" . I think we could reach 80% of people which are not able to upgrade to php 5.1.4 . Only to put attention to Cpanel devepoler that it's time to solve the problem with easyapache ( it's could be called troubleapache now :rolleyes: ;) )
     
  7. softwareguy

    softwareguy Member

    Joined:
    May 9, 2006
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    1
    easyapache has been a pain for me. A lot of times I have compiler (make) errors. Yes, I do also experience the MySQL error as one mentioned here, I have remedied that error by upgrading MySQL to the latest version but another easyapache bug happened with a eariler CURRENT build in which easyapache didn't compile apache with load modules.
    Updated cPanel to the latest version, seems fine for now, I hope this stays. ;)
     
  8. tweakservers

    tweakservers Well-Known Member

    Joined:
    Mar 30, 2006
    Messages:
    379
    Likes Received:
    0
    Trophy Points:
    16
    no luck to getting to php 5.1.4 on a new box configured today.
     
  9. NovemberRain

    NovemberRain Well-Known Member

    Joined:
    Sep 24, 2003
    Messages:
    93
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    İstanbul
    cPanel Access Level:
    Root Administrator
    I upgraded to php 5.1.4 with apache 1.3.36 and mysql 5.0 and didn't have any problems. (centos 3.7)

    After reading all these horror stories about easyapache in this forum, this was a bit surprise for me :) I was expecting some problems.
     
  10. Radio_Head

    Radio_Head Well-Known Member

    Joined:
    Feb 15, 2002
    Messages:
    2,051
    Likes Received:
    1
    Trophy Points:
    38

    what is your hardware ?
     
  11. azzawazzi

    azzawazzi Member

    Joined:
    Apr 21, 2006
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    Here is our current list:

    If you want PHP 4.4.X or PHP 5.1.X with Apache 1.3.x and MySQL 4.1.X:

    wget http://downloads.mysql.com/archives/mysql-4.1/MySQL-devel-4.1.13-0.glibc23.i386.rpm
    rpm -Uvh --force MySQL-devel-4.1.13-0.glibc23.i386.rpm
    service mysql restart
    cd /home
    rm -rf cpapachebuild/
    cd /scripts
    ./easyapache


    If you want PHP 4.4.X or PHP 5.1.X with Apache 1.3.x and MySQL 5.X:

    cd /usr/lib/mysql
    rename .a .a_old *.a
    rename .la .la_old *.la

    cd /home
    rm -rf cpapachebuild/
    cd /scripts
    ./easyapache

    cd /usr/lib/mysql
    rename .a_old .a *.a_old
    rename .la_old .la *.la_old

    Zend 2.6.2 works on both fine. Zend 3.0.0 works on PHP 5.1.X only when you take out versioning from the PHP build.

    Both of these have worked on all of our servers.

    Azza.
     
  12. Radio_Head

    Radio_Head Well-Known Member

    Joined:
    Feb 15, 2002
    Messages:
    2,051
    Likes Received:
    1
    Trophy Points:
    38
    ;) I was able to update my server too using easyapache (easy ?;) )
    But it was required a little tweak .


    When I was upgrading using /script/easypache I noticed that easypache
    commented out these lines

    #LoadModule php4_module libexec/libphp4.so
    and
    #AddModule mod_php4.c

    and php was not working .

    I added these 2 lines

    LoadModule php5_module libexec/libphp5.so
    (exactly below #LoadModule php4_module libexec/libphp4.so)

    and
    AddModule mod_php5c
    (exactly below #ddModule mod_php4.c)

    I restarted apache and php 5.1.4 worked fine ;)


    Remain the fact that easypache should be called troubleapache :D :D ;)
     
  13. jackie46

    jackie46 BANNED

    Joined:
    Jul 25, 2005
    Messages:
    537
    Likes Received:
    0
    Trophy Points:
    0
    It commented them out because you probably compiled by selecting phpsuexec. Thats the only time i know it coments out those lines.
     
  14. Radio_Head

    Radio_Head Well-Known Member

    Joined:
    Feb 15, 2002
    Messages:
    2,051
    Likes Received:
    1
    Trophy Points:
    38
  15. Radio_Head

    Radio_Head Well-Known Member

    Joined:
    Feb 15, 2002
    Messages:
    2,051
    Likes Received:
    1
    Trophy Points:
    38
    In other words to have php 5.1.4 on my server (cli without phpsuxec) I followed this procedure

    http://forums.cpanel.net/showthread.php?t=48505&p=231493
    (install latest zend 3 and php 5.1.4)

    Then I modified apache httpdconf as follow

    LoadModule php5_module libexec/libphp5.so
    (exactly below #LoadModule php4_module libexec/libphp4.so)

    and
    AddModule mod_php5c
    (exactly below #ddModule mod_php4.c)


    php 5.1.4 works perfectly .
     
  16. forlinuxsupport

    forlinuxsupport Well-Known Member
    PartnerNOC

    Joined:
    Dec 22, 2004
    Messages:
    386
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    here is my contribution.

    Please change the poll to read "WERE you able to ....."

    :)
     
  17. Radio_Head

    Radio_Head Well-Known Member

    Joined:
    Feb 15, 2002
    Messages:
    2,051
    Likes Received:
    1
    Trophy Points:
    38
    poll bump :rolleyes:
     
  18. jackie46

    jackie46 BANNED

    Joined:
    Jul 25, 2005
    Messages:
    537
    Likes Received:
    0
    Trophy Points:
    0
    Oh really? I cant even get MySQL to upgrade from 4.1.10 -> 4.1.18 or .19 using upcp. Does upcp completely skip MySQL updates for Freebsd or what is the solution to this? Or do i need to go to the port tree to upgrade MySQL? I though UPCP was supposed to keep all 3rd party applications up-to-date like it does pretty much on RH.
     
  19. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider

    FreeBSD updates are at the mercy of FreeBSD. However if its failing, there may be a problem with your ports/portsupgrade install.
     
  20. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    mysql 4.1.19 or 5.0.21 is required on linux to run php 5.
     
Loading...

Share This Page