watchdog_task: NIC Link is Up 10 Mbps Full Duplex

Zion Ahead

Well-Known Member
Nov 10, 2006
347
0
166
My server locked up twice today (stopped pinging out of the blue). First reboot went into fsck mode successfully completed anyway.

/var/log/messages shows this:

Oct 7 03:30:03 server kernel: Fatal resource shortage: numiptent, UB 108.
Oct 7 05:40:03 server last message repeated 2 times
Oct 7 05:40:03 server kernel: Fatal resource shortage: numiptent, UB 108.
Oct 7 12:02:01 server kernel: VPS: 107: stopped
Oct 7 12:06:23 server kernel: e1000: eth0: e1000_watchdog_task: NIC Link is Down
Oct 7 12:06:26 server kernel: e1000: eth0: e1000_watchdog_task: NIC Link is Up 10 Mbps Full Duplex
Oct 7 12:06:38 server kernel: e1000: eth0: e1000_watchdog_task: NIC Link is Down
Oct 7 12:06:40 server kernel: e1000: eth0: e1000_watchdog_task: NIC Link is Up 10 Mbps Full Duplex
Oct 7 12:06:44 server kernel: e1000: eth0: e1000_watchdog_task: NIC Link is Down
Oct 7 12:38:51 server shutdown: shutting down for system halt
Oct 7 12:06:23 server kernel: e1000: eth0: e1000_watchdog_task: NIC Link is Down
Oct 7 12:06:26 server kernel: e1000: eth0: e1000_watchdog_task: NIC Link is Up 10 Mbps Full Duplex
Oct 7 12:06:38 server kernel: e1000: eth0: e1000_watchdog_task: NIC Link is Down
Oct 7 12:06:40 server kernel: e1000: eth0: e1000_watchdog_task: NIC Link is Up 10 Mbps Full Duplex
Oct 7 12:06:44 server kernel: e1000: eth0: e1000_watchdog_task: NIC Link is Down
Oct 7 12:38:51 server shutdown: shutting down for system halt
Settings for eth0:
Supported ports: [ TP ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Full
Supports auto-negotiation: Yes
Advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Full
Advertised auto-negotiation: Yes
Speed: 10Mb/s
Duplex: Full
Port: Twisted Pair
PHYAD: 0
Transceiver: internal
Auto-negotiation: on
Supports Wake-on: umbg
Wake-on: d
Current message level: 0x00000007 (7)
Link detected: yes
It appears the main problem is:

Oct 7 18:46:56 server kernel: e1000: eth0: e1000_watchdog_task: NIC Link is Up 10 Mbps Full Duplex

Kernel: 2.6.9-023stab044.11-enterprise #1 SMP
O/S: CentOS release 4.3 (Final)

Hardware confirmed ok.
 

AndyReed

Well-Known Member
PartnerNOC
May 29, 2004
2,217
4
193
Minneapolis, MN
My server locked up twice today (stopped It appears the main problem is:

Oct 7 18:46:56 server kernel: e1000: eth0: e1000_watchdog_task: NIC Link is Up 10 Mbps Full Duplex

Kernel: 2.6.9-023stab044.11-enterprise #1 SMP
O/S: CentOS release 4.3 (Final)

Hardware confirmed ok.
What kind of motherboard are you using?

It is likely that the e1000 overheats and will look like it is being disconnected.

Make sure that your co-lo room has good air conditioning system, and the case of your server has a very good airflow.

Adding a heatsink or a fan near the Ethernet chip, and/or adding a heat sink on the motherboad might correct this issue.