The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Ways to redirect domain

Discussion in 'General Discussion' started by mariaasuka24, Feb 5, 2015.

  1. mariaasuka24

    mariaasuka24 Registered

    Apr 14, 2014
    Likes Received:
    Trophy Points:
    cPanel Access Level:
    Website Owner
    Hello all!
    We have just had a customer call us with a strange occurrence regarding Add on Domains and the redirections that are set up with it. I have been able to replicate it on my own server and need to understand why this is the case.

    This is the process to follow.

    * Add a new domain under Add-on Domains - make sure that the path you have is inside the primary accounts public_html
    * Create a global redirection on the Add-on domain and redirect it as required to another domain or to a page inside the add-on domain.
    * Create additional redirections for that add-on domain.
    * create redirections for the primary domain
    * Attempt to modify the Global Redirection on the add-on domain and 2 things will happen - you will lose all the redirections for the add-on domain and the global redirection will also disappear. (stating that the redirection is disabled)

    This is where it gets confusing. If i create ANY of the redirections for the add-on domain - all the redirections magically re-appear and the global redirection is back in place.

    What my customer wants to do is simply to remove the global redirect on the add-on domain without having to delete and re-add the add-on domain.

    Any advise would be great.
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Apr 11, 2011
    Likes Received:
    Trophy Points:
    cPanel Access Level:
    Root Administrator
    Hello :)

    I've reproduced part of the issue you have explained, but the global redirection is not disappearing in my tests. Could you open a support ticket using the link in my signature so we can attempt to reproduce the issue on your server and open an internal case if necessary? You can post the ticket number here so we can update this thread with the outcome.

    Thank you.

Share This Page